summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-07-06 19:01:19 -0700
committerPatrick McLean <chutzpah@gentoo.org>2017-07-06 19:01:19 -0700
commitaee7d9396bab3dc1864dc1c6a38ede5a3c952213 (patch)
treeb94cfa9231326e8d3d42937d1be627c5535187d4 /media-sound/pithos
parentmedia-sound/pithos: Add python3_5 to PYTHON_COMPAT (diff)
downloadgentoo-aee7d9396bab3dc1864dc1c6a38ede5a3c952213.tar.gz
gentoo-aee7d9396bab3dc1864dc1c6a38ede5a3c952213.tar.bz2
gentoo-aee7d9396bab3dc1864dc1c6a38ede5a3c952213.zip
media-sound/pithos: Version bump to 1.3.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-sound/pithos')
-rw-r--r--media-sound/pithos/Manifest1
-rw-r--r--media-sound/pithos/files/pithos-1.3.1-dont-try-to-update-icon-cache.patch20
-rw-r--r--media-sound/pithos/pithos-1.3.1.ebuild92
3 files changed, 113 insertions, 0 deletions
diff --git a/media-sound/pithos/Manifest b/media-sound/pithos/Manifest
index f4f98bf8f97a..ba61d9ed8140 100644
--- a/media-sound/pithos/Manifest
+++ b/media-sound/pithos/Manifest
@@ -1,3 +1,4 @@
DIST pithos-1.0.1.tar.gz 112230 SHA256 67b83927d5111067aefbf034d23880f96b1a2d300464e8491efa80e97e67f50f SHA512 ab1b671ae4c75534782e64f61eb4bdb63781ac895e1e07f4c6bc64aa56033a0fb301e6f673ea2ddea6e51c1aa69f3fc4e81d7ec4db80cfd7843550424a5cff26 WHIRLPOOL eaa1fe7341f639624847bf574a9b4f35d28a41a9825cdb7cd84ca22464043a5da74ff4dbf914b874077612412449b38d66f80b69e82a7befffdf19d54155c3c9
DIST pithos-1.1.1.tar.gz 112793 SHA256 4424534bbf7ab3d3d6c51764d689606fd0df214422eb79ccc91a8981f95d7dce SHA512 8813e5218b448cac64d9787388f3bfa8e7a06cc785c3f7ca6bdce5dee2fdb393d9019169256a01f43fd610ebfd8e07d6fcdafeb476c18d88d8de87895c5b9c2f WHIRLPOOL 401cbd1e3cbeaa0457e4e75be3f2fe04e0ca252274e1539fe9de0777e2c77c3e50e4b4e401bbca0ff0371c8aedc08920384b87016f8357b2caadd3f86e90247d
DIST pithos-1.1.2.tar.gz 115119 SHA256 560cc42410981c4578505bf67635c75d11b63fe8ff5d4d73e154e016e7fe5465 SHA512 3eb5177de64f3e7e0a19409adebb1bf77a4c5d6226b6cc4a536611662a89599dc6175c92883af5f4115b6599ba94a8439fef769b0879a05fa48685598c4cdd01 WHIRLPOOL ed6b5170c3ffbf6f687020f3492902831d37ba14eae0ac26ad075225affb636891ad4106054ae627d8b87b7cb7be5ad45d5b04cf3135b6928ad07c9814e0d548
+DIST pithos-1.3.1.tar.gz 119658 SHA256 95d6bfd961a574f1ea8b42b5bf05680eff4ab7a5f0172a9987ddd9411b91a219 SHA512 c06715516992e4aa8bb3b200035ee10ef8dcec9491d32af0fb3f4e176d0ad5313a437f228747d5d716a29d2fe5b93ddd3704aa4fe674ce3be5a17eaad13b0da4 WHIRLPOOL b9d6bd12971417d17f77fb1466797d4e05d5c38f87a36973044295c785882e8c58829c67fc4095b20d38794c29ce412504350432470d045eb8e24f519030be67
diff --git a/media-sound/pithos/files/pithos-1.3.1-dont-try-to-update-icon-cache.patch b/media-sound/pithos/files/pithos-1.3.1-dont-try-to-update-icon-cache.patch
new file mode 100644
index 000000000000..5e1b5da91c9a
--- /dev/null
+++ b/media-sound/pithos/files/pithos-1.3.1-dont-try-to-update-icon-cache.patch
@@ -0,0 +1,20 @@
+diff --git a/Makefile.am b/Makefile.am
+index 0c5e1cb..b413774 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -85,13 +85,11 @@ ubuntu_light_DATA = data/icons/ubuntu-mono-light/16x16/apps/io.github.Pithos-tra
+ ubuntu_darkdir = $(datadir)/icons/ubuntu-mono-dark/16x16/apps
+ ubuntu_dark_DATA = data/icons/ubuntu-mono-dark/16x16/apps/io.github.Pithos-tray.svg
+
+-UPDATE_ICON_CACHE = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor || :
+-
+ install-data-hook:
+- $(UPDATE_ICON_CACHE);
++ :;
+
+ uninstall-hook:
+- $(UPDATE_ICON_CACHE);
++ :;
+
+ BUILT_SOURCES = pithos.gresource
+ SUBDIRS = po
diff --git a/media-sound/pithos/pithos-1.3.1.ebuild b/media-sound/pithos/pithos-1.3.1.ebuild
new file mode 100644
index 000000000000..c6662ebaba08
--- /dev/null
+++ b/media-sound/pithos/pithos-1.3.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python3_4 python3_5)
+inherit autotools gnome2-utils python-r1
+
+if [[ ${PV} =~ [9]{4,} ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/pithos/pithos.git
+ https://github.com/pithos/pithos.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Pandora.com client for the GNOME desktop"
+HOMEPAGE="http://pithos.github.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify appindicator +keybinder"
+
+RDEPEND="
+ dev-python/pylast[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.12[${PYTHON_USEDEP}]
+ dev-libs/appstream-glib[introspection]
+ x11-libs/pango[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0[aac,http,mp3]
+ >=x11-libs/gtk+-3.14:3[introspection]
+ x11-themes/gnome-icon-theme-symbolic
+ libnotify? ( x11-libs/libnotify[introspection] )
+ appindicator? ( dev-libs/libappindicator:3[introspection] )
+ keybinder? ( dev-libs/keybinder:3[introspection] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.1-dont-try-to-update-icon-cache.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+ python_copy_sources
+}
+
+pithos_src_configure() {
+ pushd "${BUILD_DIR}" || die
+ econf UPDATE_ICON_CACHE=":"
+ popd || die
+}
+
+src_configure() {
+ python_foreach_impl pithos_src_configure
+}
+
+pithos_src_compile() {
+ pushd "${BUILD_DIR}" || die
+ emake
+ popd || die
+}
+
+src_compile() {
+ python_foreach_impl pithos_src_compile
+}
+
+pithos_src_install() {
+ pushd "${BUILD_DIR}" || die
+ emake DESTDIR="${D}" install
+ python_doscript "${D}"/usr/bin/pithos
+ popd || die
+}
+
+src_install() {
+ python_foreach_impl pithos_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}