summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/podget
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/podget')
-rw-r--r--media-sound/podget/Manifest3
-rw-r--r--media-sound/podget/metadata.xml12
-rw-r--r--media-sound/podget/podget-0.6.15.ebuild33
-rw-r--r--media-sound/podget/podget-0.6.9.ebuild30
-rw-r--r--media-sound/podget/podget-0.6.ebuild28
5 files changed, 106 insertions, 0 deletions
diff --git a/media-sound/podget/Manifest b/media-sound/podget/Manifest
new file mode 100644
index 000000000000..fa62cb856dc6
--- /dev/null
+++ b/media-sound/podget/Manifest
@@ -0,0 +1,3 @@
+DIST podget-0.6.15.tar.gz 33590 SHA256 b2e5552d0ed6371bea9864b30592c4acabdfb7d8c0409e1adc6daaaa872b52fe SHA512 1442a1d10b506926bec98e642cf8a060e9a2205c692a453c5e0444e36fb7afdf55b975eac27bb230eb0483993f6526b6151e9f153e2eac9d6cbe6967f054e55a WHIRLPOOL 507f28428fe0dc719a74e4aa01e882a7aead9452feeaa5c208c1706b8d0703298362b8f08c802ee5e10d94d4dc9c80db321b305775f4d81e5a75b76045614b8e
+DIST podget-0.6.tar.gz 32988 SHA256 58b3ace69295010b39f11dbf592109dfcc37684e8c08f71ea30c726d5f830d3a
+DIST podget_0.6.9.tar.gz 30329 SHA256 7f676bf73568b18a3a9a3b8d5207a1b8a3a9da6869898c83bb36440983fa79a7 SHA512 f38ea35cda98346d13f50a900d8519d70ad6198e7237717f4e59e0149c92c9d9957c5106c4a2dc6235eb52ec6a6f69d1ea6710165fe5f7286d1882f19225f28b WHIRLPOOL 741e401a1789febb649cd553a512e350a6866e938ddd8588e986fa7ca32bb217df786904be0c80f775804d1c1d84380b4f78c8db8e28a4830d3bdd531978a0cc
diff --git a/media-sound/podget/metadata.xml b/media-sound/podget/metadata.xml
new file mode 100644
index 000000000000..1cae8b0fa16a
--- /dev/null
+++ b/media-sound/podget/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>kitcat490@gmail.com</email>
+ <name>Michael Niehoff</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">podget</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/podget/podget-0.6.15.ebuild b/media-sound/podget/podget-0.6.15.ebuild
new file mode 100644
index 000000000000..d114a6e4ada7
--- /dev/null
+++ b/media-sound/podget/podget-0.6.15.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="${PN}-${PV}"
+
+DESCRIPTION="A simple podcast aggregator written in bash"
+HOMEPAGE="http://podget.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-apps/grep
+ sys-apps/sed
+ app-text/tofrodos
+ net-misc/wget"
+
+src_compile() {
+ # There is a Makefile that we don't use
+ :
+}
+
+src_install() {
+ dobin ${PN}
+ doman DOC/${PN}.7
+ dodoc -r Changelog README SCRIPTS/
+}
diff --git a/media-sound/podget/podget-0.6.9.ebuild b/media-sound/podget/podget-0.6.9.ebuild
new file mode 100644
index 000000000000..0190e74e8815
--- /dev/null
+++ b/media-sound/podget/podget-0.6.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="A simple podcast aggregator written in bash"
+HOMEPAGE="http://podget.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # There is a Makefile that we don't use
+ :
+}
+
+src_install() {
+ dobin podget
+ doman DOC/podget.7
+ dodoc -r Changelog README SCRIPTS/
+}
diff --git a/media-sound/podget/podget-0.6.ebuild b/media-sound/podget/podget-0.6.ebuild
new file mode 100644
index 000000000000..7a5161fad2c7
--- /dev/null
+++ b/media-sound/podget/podget-0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A simple podcast aggregator written in bash"
+HOMEPAGE="http://podget.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # There is a Makefile that we don't use
+ :
+}
+
+src_install() {
+ dobin podget
+ doman DOC/podget.7
+ dodoc -r Changelog README SCRIPTS/
+}