summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/potamus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/potamus')
-rw-r--r--media-sound/potamus/Manifest2
-rw-r--r--media-sound/potamus/metadata.xml5
-rw-r--r--media-sound/potamus/potamus-0.12.ebuild42
-rw-r--r--media-sound/potamus/potamus-14.ebuild46
4 files changed, 95 insertions, 0 deletions
diff --git a/media-sound/potamus/Manifest b/media-sound/potamus/Manifest
new file mode 100644
index 000000000000..2f100a797a9f
--- /dev/null
+++ b/media-sound/potamus/Manifest
@@ -0,0 +1,2 @@
+DIST potamus-0.12.tar.gz 127788 SHA256 5034e09c8646cbb299f895541e155b9d7012597210bc8b0ba213812928525e2d SHA512 ab88031eaa4608b4513aec75d86ab1b16e6e192926d0ca7b0616845ecb9a564f12affba9ed2a3fc903b8b9ac5481a1aabab8904df5546a3ea6a9f6f3eccc1ba0 WHIRLPOOL 4491a23f1e87fee6dab5e279630de4c1f5a85106263b6c11d2410c511ac838bd30e36057bf3a42960514559bbb71714f5839659b49ce04c15ac151e2cc609b7a
+DIST potamus-14.tar.gz 163164 SHA256 ae271a7101dbbd75c95faaa0afcd311cae24311a1c4eb01e73d1ffce43667194 SHA512 d6192e9e9114f4f88619751529718afb94f113613f23432646c1d5fa707a82ad10c70425135a5ca5a076b68a36ededdb01d73bc1dc6a92e2bdb644d624303394 WHIRLPOOL fc70d8043fec093be4781cdee5e615131f9bea3c375c9f22b290d4777b121c911c402298bac6b9253deb791580a98f224abd751d4912c46a1cb939d50a562b23
diff --git a/media-sound/potamus/metadata.xml b/media-sound/potamus/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/potamus/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/potamus/potamus-0.12.ebuild b/media-sound/potamus/potamus-0.12.ebuild
new file mode 100644
index 000000000000..06e4f90bb81f
--- /dev/null
+++ b/media-sound/potamus/potamus-0.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit gnome2
+
+DESCRIPTION="a lightweight audio player with a simple interface and an emphasis on high audio quality"
+HOMEPAGE="http://offog.org/code/potamus.html"
+SRC_URI="http://offog.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/libglade-2
+ media-libs/libao
+ media-libs/libsamplerate
+ media-libs/libvorbis
+ media-libs/libmad
+ media-libs/audiofile
+ media-libs/libmodplug
+ virtual/ffmpeg
+ media-libs/flac
+ media-sound/jack-audio-connection-kit"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ sed -i -e \
+ 's:CODEC_TYPE_AUDIO:AVMEDIA_TYPE_AUDIO:g' \
+ src/input-avcodec.c || die
+}
+
+src_install() {
+ default
+}
diff --git a/media-sound/potamus/potamus-14.ebuild b/media-sound/potamus/potamus-14.ebuild
new file mode 100644
index 000000000000..1115eccdebe2
--- /dev/null
+++ b/media-sound/potamus/potamus-14.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit gnome2
+
+DESCRIPTION="a lightweight audio player with a simple interface and an emphasis on high audio quality"
+HOMEPAGE="http://offog.org/code/potamus.html"
+SRC_URI="http://offog.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="audiofile flac mad modplug vorbis +ao jack"
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/libglade-2
+ media-libs/libsamplerate
+ virtual/ffmpeg
+ audiofile? ( media-libs/audiofile )
+ flac? ( media-libs/flac )
+ mad? ( media-libs/libmad )
+ modplug? ( media-libs/libmodplug )
+ vorbis? ( media-libs/libvorbis )
+ ao? ( media-libs/libao )
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable audiofile input-audiofile) \
+ $(use_enable flac input-flac) \
+ $(use_enable mad input-mad) \
+ $(use_enable modplug input-modplug) \
+ $(use_enable vorbis input-vorbis) \
+ $(use_enable ao output-ao) \
+ $(use_enable jack output-jack)
+
+}
+
+src_install() {
+ default
+}