summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-11-04 08:56:58 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-11-04 08:56:58 +0100
commit6913da8e5e7db0c41d7733830deb88d68d31bafa (patch)
tree16b3c594ebfc4fd055fded388f88ccfee6303e2a /media-sound/sidplayfp
parentmedia-sound/drumstick: dropped obsolete 2.6.1-r1 (diff)
downloadgentoo-6913da8e5e7db0c41d7733830deb88d68d31bafa.tar.gz
gentoo-6913da8e5e7db0c41d7733830deb88d68d31bafa.tar.bz2
gentoo-6913da8e5e7db0c41d7733830deb88d68d31bafa.zip
media-sound/sidplayfp: bump to 2.11.0
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/sidplayfp')
-rw-r--r--media-sound/sidplayfp/Manifest1
-rw-r--r--media-sound/sidplayfp/sidplayfp-2.11.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/sidplayfp/Manifest b/media-sound/sidplayfp/Manifest
index 19d1d8df933e..b7d53719b3e3 100644
--- a/media-sound/sidplayfp/Manifest
+++ b/media-sound/sidplayfp/Manifest
@@ -1,2 +1,3 @@
DIST sidplayfp-2.10.0.tar.gz 244263 BLAKE2B 62406febe1ba9074779b3ed77e5ceddea35d472eae94bfec13245ce9503c812d5cefeb0fa1d870e00380535145a031427463d58c8d1262ff8a43a2b470b58073 SHA512 7d59f21690d8219fd2d077541ffe90499f4b44b79e1fc4f43f3f048a01e935ad7b4723cd111acb9c9a287a1b8960b187a8e82463b9725a3171d98c32e391b15f
+DIST sidplayfp-2.11.0.tar.gz 252126 BLAKE2B 0ef141ca32c3f91dad67a54bf253da806242fb30294be97b44ded23490bb30d05dfc63593bb3c5b05a1bae48228d0ce3c31c35dba15dea1db70ed36692ef060d SHA512 455e8a81e7540f7fa5b97a11c5ab45cb87d77210569dd62ea3bfee8149d56b884eafb23ae404e806b92bf62f40bbf560ecfda76073477caf3fa960a1f52933be
DIST sidplayfp-2.9.0.tar.gz 247965 BLAKE2B 11ff3c33360aca182886418bda8dbfb534de6c6e76b854dfaf78599ce388b5c493221cf8d0f13fdb5ccb7cae7d352484b56505cbef3f955cac5cb26d933d35e1 SHA512 2a59cca74456e04ff6cd5bf3c8f47eb8687e577cd907979188713d38f1602ec8933d467222ae4f5e630116bc71832435bd911901c666b3285c796bb1c5d03393
diff --git a/media-sound/sidplayfp/sidplayfp-2.11.0.ebuild b/media-sound/sidplayfp/sidplayfp-2.11.0.ebuild
new file mode 100644
index 000000000000..2d76084b9af7
--- /dev/null
+++ b/media-sound/sidplayfp/sidplayfp-2.11.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sidplay2 fork with resid-fp"
+HOMEPAGE="https://sourceforge.net/projects/sidplay-residfp/"
+SRC_URI="https://downloads.sourceforge.net/sidplay-residfp/${PN}/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa oss pulseaudio"
+
+BDEPEND="virtual/pkgconfig"
+CDEPEND="
+ media-libs/libsidplayfp
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-libs/libpulse )
+"
+RDEPEND="
+ ${CDEPEND}
+ media-plugins/mpg123-output-plugins
+"
+DEPEND="${CDEPEND}
+ oss? ( virtual/os-headers )
+"
+
+DOCS=( AUTHORS README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.4-musl-limits.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use alsa; then
+ sed -i -e 's:alsa >= 1.0:dIsAbLe&:' configure || die
+ fi
+
+ if ! use pulseaudio; then
+ sed -i -e 's:libpulse-simple >= 1.0:dIsAbLe&:' configure || die
+ fi
+}
+
+src_configure() {
+ export ac_cv_header_linux_soundcard_h=$(usex oss)
+
+ econf
+}