summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomoya Tabuchi <t@tomoyat1.com>2017-01-14 12:59:44 +0900
committerMatthew Thode <prometheanfire@gentoo.org>2017-01-13 23:38:57 -0600
commite8214ea1d7129abeea0720cfcab211128910d827 (patch)
treeb71b5938bca5c8a0c763581e402d4fc2642e6848 /media-sound/spotify
parentdev-utils/ctags: amd64 stable wrt bug #602278 (diff)
downloadgentoo-e8214ea1d7129abeea0720cfcab211128910d827.tar.gz
gentoo-e8214ea1d7129abeea0720cfcab211128910d827.tar.bz2
gentoo-e8214ea1d7129abeea0720cfcab211128910d827.zip
media-sound/spotify: bump to version 10.0.47
Package-Manager: portage-2.3.0 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'media-sound/spotify')
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.47.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index 4750e3dd79e2..abf8a6032b2e 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,4 @@
DIST spotify-client_1.0.45.186.g3b5036d6-28_i386.deb 73486180 SHA256 8cf17f8938173bd3f5c3092345c8421c5d391aaa46839502ec547e5a57fcedf9 SHA512 d513ffe435a41d03b02a0b4efb49e69af40e496488199d4996b54086f46996d531ad6bd38e101e95b1e0ed7946d7c2e81c0fd25088a42a47c99f2f1d947e40a9 WHIRLPOOL 13775bf42728896ec68d46038202c2f2523fb15837c88e2262d4f124a50ff0c6e5628bfadb64db58c927399e223314aa18bbc12a56213b8ec0785dc558a7296a
DIST spotify-client_1.0.45.186.g3b5036d6-95_amd64.deb 72182494 SHA256 e19a5277ea7dee8796edcc49de07036b32cac0ce553ef2aed7416dff6bf8fb3a SHA512 a33c5517d27a6eef445dbfc13006189a82b6a3362bd2b40b81a040f60870e5700e45ba288c9caef1848f1f36d197627b8c2c7f81c48dc00d0bce32f1a7a34cb1 WHIRLPOOL 6d0ba8cb606a6c01f275c9710af3fc7b596bcfd1dc5005a2174a3e75364a9ff33c813d377b4cc7c38e54a8de3b263e2d1480cdd696b5e2d7d31a41072a7d2361
+DIST spotify-client_1.0.47.13.gd8e05b1f-16_i386.deb 73083922 SHA256 646a5e90ede734d215e807c35165796b89d68b5c3f3e0363208cc204d1146692 SHA512 22e9c4fc45c17f7f0dd910981eeeb76e1db4b413a082ea684150616d7c8af698de1f5e101b82d23e429ec0ef8197c86e74534188f7bcb056afb2335aaf4e72ac WHIRLPOOL ea3cbc2e50a0dcf87cb3dab98439500e44d16568168ebfbd450c5fde35f450eb67ccb0762781e7dad7697f94df29d9a055cd0d1763ad3cdadb4d59f80e8977d3
+DIST spotify-client_1.0.47.13.gd8e05b1f-47_amd64.deb 71870788 SHA256 7f32e25aa7188ec74a93d240b994f1126fc034325b66ec6549e7006e05dee900 SHA512 b5f51ae7c034b47264e7f897f28ca4f91f37bf1c01fa70b78393415cab8bcb9064b8a9842d43d4ab2ad1b7d4621dcb633ef1671dc0996e3734a9433d4749416c WHIRLPOOL e39b3fb696b445c78fd929785571f1821ef0ccf9b0811b24df8a69ce813c63fe7920252e477d3f4b7d336b78e3bc1144ada26c7c05ef6c596d2554f4f8174255
diff --git a/media-sound/spotify/spotify-1.0.47.ebuild b/media-sound/spotify/spotify-1.0.47.ebuild
new file mode 100644
index 000000000000..e234521c6a3c
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.47.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+BUILD_ID="13.gd8e05b1f"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID}-47_amd64.deb )
+ x86? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID}-16_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+# zenety needed for filepicker
+RDEPEND="
+ ${DEPEND}
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl[ssl,curl_ssl_openssl]
+ net-print/cups[ssl]
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ dev-python/pygobject:3
+ dev-python/dbus-python
+ pulseaudio? ( media-sound/pulseaudio )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}