summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/takcd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/takcd')
-rw-r--r--media-sound/takcd/Manifest1
-rw-r--r--media-sound/takcd/files/takcd-0.10-overflow.patch13
-rw-r--r--media-sound/takcd/metadata.xml5
-rw-r--r--media-sound/takcd/takcd-0.10.ebuild27
4 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/takcd/Manifest b/media-sound/takcd/Manifest
new file mode 100644
index 000000000000..c8985a61dfaa
--- /dev/null
+++ b/media-sound/takcd/Manifest
@@ -0,0 +1 @@
+DIST takcd-0.10.tar.gz 95457 RMD160 2784989499ba9e999b1b59c8749d702de1ba446e SHA1 a9b4e607a4c2f091d4a7c62539180d823279c45a SHA256 2871ace2ec79b09ea8eff80a2074105fdde33d3fb0a0572dc8e2dd931c8d4802
diff --git a/media-sound/takcd/files/takcd-0.10-overflow.patch b/media-sound/takcd/files/takcd-0.10-overflow.patch
new file mode 100644
index 000000000000..c3e7e16d286a
--- /dev/null
+++ b/media-sound/takcd/files/takcd-0.10-overflow.patch
@@ -0,0 +1,13 @@
+diff --git a/config_api.c b/config_api.c
+index b62e41c..2b6a6cf 100644
+--- a/config_api.c
++++ b/config_api.c
+@@ -41,7 +41,7 @@ static void on_change(config_t *conf)
+ int config_open(config_t *conf, const char *filename, int flag)
+ {
+ struct stat st;
+- char mode[2];
++ char mode[3];
+
+ /* set fopen() mode or return if flag is not valid */
+ if (flag == C_WRITE) {
diff --git a/media-sound/takcd/metadata.xml b/media-sound/takcd/metadata.xml
new file mode 100644
index 000000000000..ae573a60407f
--- /dev/null
+++ b/media-sound/takcd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/takcd/takcd-0.10.ebuild b/media-sound/takcd/takcd-0.10.ebuild
new file mode 100644
index 000000000000..912c49debf10
--- /dev/null
+++ b/media-sound/takcd/takcd-0.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+DESCRIPTION="Command line CD player"
+HOMEPAGE="http://bard.sytes.net/takcd/"
+SRC_URI="http://bard.sytes.net/takcd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ~mips ~ppc sparc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-overflow.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ doman *.1
+ dodoc AUTHORS ChangeLog NEWS README README.takmulti TODO
+}