summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/volwheel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/volwheel')
-rw-r--r--media-sound/volwheel/Manifest1
-rw-r--r--media-sound/volwheel/files/volwheel-0.2.8-perl516.patch36
-rw-r--r--media-sound/volwheel/metadata.xml8
-rw-r--r--media-sound/volwheel/volwheel-0.2.8-r1.ebuild34
4 files changed, 79 insertions, 0 deletions
diff --git a/media-sound/volwheel/Manifest b/media-sound/volwheel/Manifest
new file mode 100644
index 000000000000..61d96dd4e38e
--- /dev/null
+++ b/media-sound/volwheel/Manifest
@@ -0,0 +1 @@
+DIST volwheel-0.2.8.tar.gz 43140 SHA256 a14e9b3fb831677937396488466ebbb2a7030f76cf2cc404d63dd0ea8d5b9948 SHA512 ee2d121d2a9e2c987407a30187a313db128f1557932d003421e0fbda683cf80d52b5fb3c4c4ab2d07b642e86bb580bb3764a1c091ea57f5068660a035e78721b WHIRLPOOL ba982fac83ef42ae9403fd326b6aab6d330022c8b0c70f684e35fc620271469b2c11622bd9c5b9f733522f6493bfe9a3a892f63db9db3262f27be5b5b6734243
diff --git a/media-sound/volwheel/files/volwheel-0.2.8-perl516.patch b/media-sound/volwheel/files/volwheel-0.2.8-perl516.patch
new file mode 100644
index 000000000000..130d9b7c331f
--- /dev/null
+++ b/media-sound/volwheel/files/volwheel-0.2.8-perl516.patch
@@ -0,0 +1,36 @@
+http://code.google.com/p/olwtools/issues/detail?id=8
+
+--- install.pl
++++ install.pl
+@@ -2,7 +2,6 @@
+
+ use strict;
+ use warnings;
+-use Shell qw(install cp);
+
+ my $package = "volwheel";
+
+@@ -33,17 +32,17 @@
+ system("sed -i 's|/usr/local|$prefix|g\' volwheel");
+ }
+
+-my $output = install ("-v -d {$bindir,$libdir,$datadir,$hicolor,$desktop}");
++my $output = qx|install -v -d {$bindir,$libdir,$datadir,$hicolor,$desktop}|;
+ print $output;
+-$output = install ("-v -m755 volwheel $bindir");
++$output = qx|install -v -m755 volwheel $bindir|;
+ print $output;
+-$output = install ("-v -m644 lib/* $libdir");
++$output = qx|install -v -m644 lib/* $libdir|;
+ print $output;
+-$output = cp ("-v -r icons $datadir/");
++$output = qx|cp -v -r icons $datadir/|;
+ print $output;
+-$output = install ("-v -m644 icons/volwheel.svg $hicolor");
++$output = qx|install -v -m644 icons/volwheel.svg $hicolor|;
+ print $output;
+-$output = install ("-v -m644 volwheel.desktop $desktop");
++$output = qx|install -v -m644 volwheel.desktop $desktop|;
+
+ print "\nVolWheel has been succesfully installed.\n\n";
+
diff --git a/media-sound/volwheel/metadata.xml b/media-sound/volwheel/metadata.xml
new file mode 100644
index 000000000000..b49e5b281a6f
--- /dev/null
+++ b/media-sound/volwheel/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="google-code">olwtools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/volwheel/volwheel-0.2.8-r1.ebuild b/media-sound/volwheel/volwheel-0.2.8-r1.ebuild
new file mode 100644
index 000000000000..780c3446aaf5
--- /dev/null
+++ b/media-sound/volwheel/volwheel-0.2.8-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils
+
+DESCRIPTION="A volume control trayicon with mouse wheel support"
+HOMEPAGE="http://oliwer.net/b/volwheel.html"
+SRC_URI="http://olwtools.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~mips x86"
+IUSE="alsa"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/gtk2-perl
+ alsa? ( media-sound/alsa-utils )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-perl516.patch
+ sed -i -e '/^Encoding/d' ${PN}.desktop || die
+}
+
+src_install() {
+ ./install.pl prefix=/usr destdir="${D}" || die
+ dodoc ChangeLog README TODO
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }