summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/wavegain
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/wavegain')
-rw-r--r--media-sound/wavegain/Manifest2
-rw-r--r--media-sound/wavegain/metadata.xml5
-rw-r--r--media-sound/wavegain/wavegain-1.3.0.ebuild31
-rw-r--r--media-sound/wavegain/wavegain-1.3.1.ebuild31
4 files changed, 69 insertions, 0 deletions
diff --git a/media-sound/wavegain/Manifest b/media-sound/wavegain/Manifest
new file mode 100644
index 000000000000..c85b8d0afed4
--- /dev/null
+++ b/media-sound/wavegain/Manifest
@@ -0,0 +1,2 @@
+DIST wavegain-1.3.0srcs.zip 75536 SHA256 0845abed38d361b240ecc061eb9fdf60c7d61908fec943e4c181930ae519c214 SHA512 00c30e37c157cb31e9cc3220a06e9687205fe74f6fe73f81efcdc31fa8ca4abb2654845cdc405edcb7104fbd295ad4e3aff9e61dec12b1706950b53791365e12 WHIRLPOOL 95865bca2cf7223de89dc45e690eda862b105722c5d52de4958e170c8ef4c21e6c0b2a0c04afe83cd2c3afa7abfe386858f3071d4f570917d374b0f37fadff94
+DIST wavegain-1.3.1srcs.zip 72180 SHA256 773aaa8e18a0c130714f4bf21afb9ee0ba29d6c5742002191bfdf52f25b48da0 SHA512 5d0d589259e362a415a5cd5e42464b5e7c7e79c62082ebd423457b6e2d9c3d15300d854e57e2c51c66f1579394bbcdc3d754bb8363d809c2d8d5f03b09dce054 WHIRLPOOL 2a36c8b8b076e0250547041ff7fff01c240677376992aab1edb7a2e09971c39c5b33aa6731d8d34b108a55cdbb666f0bebf165daffcd6ebff59f4cdcbff271d4
diff --git a/media-sound/wavegain/metadata.xml b/media-sound/wavegain/metadata.xml
new file mode 100644
index 000000000000..3bf6bcfeb512
--- /dev/null
+++ b/media-sound/wavegain/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/wavegain/wavegain-1.3.0.ebuild b/media-sound/wavegain/wavegain-1.3.0.ebuild
new file mode 100644
index 000000000000..1ab07bbe554d
--- /dev/null
+++ b/media-sound/wavegain/wavegain-1.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="ReplayGain for WAVE audio files"
+HOMEPAGE="http://www.rarewares.org/files/others/"
+SRC_URI="http://www.rarewares.org/files/others/${P}srcs.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P/wavegain/WaveGain}
+
+src_compile(){
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} *.c -o ${PN} \
+ -DHAVE_CONFIG_H -lm || die "build failed"
+}
+
+src_install(){
+ dobin ${PN}
+}
diff --git a/media-sound/wavegain/wavegain-1.3.1.ebuild b/media-sound/wavegain/wavegain-1.3.1.ebuild
new file mode 100644
index 000000000000..64c07a789c7d
--- /dev/null
+++ b/media-sound/wavegain/wavegain-1.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="ReplayGain for WAVE audio files"
+HOMEPAGE="http://www.rarewares.org/files/others/"
+SRC_URI="http://www.rarewares.org/files/others/${P}srcs.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P/wavegain/WaveGain}
+
+src_compile(){
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} *.c -o ${PN} \
+ -DHAVE_CONFIG_H -lm || die "build failed"
+}
+
+src_install(){
+ dobin ${PN}
+}