summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-12 23:55:09 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-12 23:57:57 +0200
commit119b8abce8d0c29829b6b4e0aede4af4c014e29d (patch)
treea9d603f76472394877d14a6a38228d62d5f750db /media-sound
parentsys-fs/zfs-kmod: require !PREEMPT on arm64 only on >= 5.x kernels (diff)
downloadgentoo-119b8abce8d0c29829b6b4e0aede4af4c014e29d.tar.gz
gentoo-119b8abce8d0c29829b6b4e0aede4af4c014e29d.tar.bz2
gentoo-119b8abce8d0c29829b6b4e0aede4af4c014e29d.zip
media-sound/drumstick: 1.1.3 version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/drumstick/Manifest1
-rw-r--r--media-sound/drumstick/drumstick-1.1.3.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/media-sound/drumstick/Manifest b/media-sound/drumstick/Manifest
index 48a28d2c5197..f33d9fbb0db1 100644
--- a/media-sound/drumstick/Manifest
+++ b/media-sound/drumstick/Manifest
@@ -1 +1,2 @@
DIST drumstick-1.1.2.tar.bz2 1012371 BLAKE2B e60a5678d33db1831130037bb4a6df6da8de815a6a0ca33a167f85596f45a1d420ca4c689c756c1fd3f794fb2a097bc19878d78bfe0789a40f9eae1b306b769f SHA512 6e84fbf2ce717cdb3c669a477de65d2f32c277073d812546267c0a9556f7ead612e3140cbc412fcd560786ca024f201a1eb3ba9de4b037e3ba8d4db89e0e2e29
+DIST drumstick-1.1.3.tar.gz 1358468 BLAKE2B af4cc923d380a1da66c835a6302e47e31c17ff90ba9277fe6063e6029c3d4d087e85905487a4dae657cdbfb743d2ac6e6c5a30c0905c9bc736d8666105e52099 SHA512 41990c269c41dc011e14c9bf008b983cd3722ea52429ec7eabaa5689a6f69b1760fc766604378c30bb1dfab537b77f7522a13377b873308835a0e7701d24448e
diff --git a/media-sound/drumstick/drumstick-1.1.3.ebuild b/media-sound/drumstick/drumstick-1.1.3.ebuild
new file mode 100644
index 000000000000..fcea0b268687
--- /dev/null
+++ b/media-sound/drumstick/drumstick-1.1.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg
+
+DESCRIPTION="Qt/C++ wrapper for ALSA sequencer"
+HOMEPAGE="http://drumstick.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fluidsynth pulseaudio"
+
+BDEPEND="
+ virtual/pkgconfig
+ x11-misc/shared-mime-info
+ doc? (
+ app-doc/doxygen
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ fluidsynth? ( media-sound/fluidsynth )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+RESTRICT="test"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ if ! use fluidsynth ; then
+ sed -i -e "/pkg_check_modules(FLUIDSYNTH/d" \
+ library/rt/CMakeLists.txt \
+ library/rt-backends/CMakeLists.txt \
+ utils/vpiano/CMakeLists.txt || die
+ fi
+
+ if ! use pulseaudio ; then
+ sed -i -e "/pkg_check_modules(PULSE/d" CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ $(cmake-utils_use_find_package doc Doxygen)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && cmake-utils_src_compile doxygen
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc ; then
+ dodoc -r "${BUILD_DIR}"/doc/html
+ fi
+}