summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-14 15:15:55 +0000
committerSam James <sam@gentoo.org>2021-06-14 16:11:21 +0000
commit238d4c26092568ac7c3bb25753405909d61d8c8c (patch)
tree65b30f28d8195e56ab2c4c86acace91d8a181313 /media-sound
parentgames-action/armagetronad: drop 0.2.8.3.3-r1 (diff)
downloadgentoo-238d4c26092568ac7c3bb25753405909d61d8c8c.tar.gz
gentoo-238d4c26092568ac7c3bb25753405909d61d8c8c.tar.bz2
gentoo-238d4c26092568ac7c3bb25753405909d61d8c8c.zip
media-sound/din: fix build with GCC 11
Closes: https://bugs.gentoo.org/787185 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/din/din-50.2.ebuild1
-rw-r--r--media-sound/din/files/din-50.2-gcc11-rename-identifier.patch41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/din/din-50.2.ebuild b/media-sound/din/din-50.2.ebuild
index 4d68ab765afb..38869408d19a 100644
--- a/media-sound/din/din-50.2.ebuild
+++ b/media-sound/din/din-50.2.ebuild
@@ -35,6 +35,7 @@ REQUIRED_USE="|| ( alsa jack )"
PATCHES=(
"${FILESDIR}/${PN}-49.1-makefile.patch"
"${FILESDIR}/${PN}-48-fix-random-constants.patch"
+ "${FILESDIR}/${PN}-50.2-gcc11-rename-identifier.patch"
)
src_prepare() {
diff --git a/media-sound/din/files/din-50.2-gcc11-rename-identifier.patch b/media-sound/din/files/din-50.2-gcc11-rename-identifier.patch
new file mode 100644
index 000000000000..4d65f65b0388
--- /dev/null
+++ b/media-sound/din/files/din-50.2-gcc11-rename-identifier.patch
@@ -0,0 +1,41 @@
+https://bugs.gentoo.org/787185
+
+From 9ea918cfdfcd99fbcac64a820ddbaefb562c11a0 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Mon, 14 Jun 2021 15:06:58 +0000
+Subject: [PATCH] src/help.h: Rename __help identifier
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+__help is reserved, so we need to rename it to fix a build failure with GCC 11:
+
+ "In addition to the names documented in this manual, reserved names include all
+ external identifiers (global functions and variables) that begin with an
+ underscore (‘_’) and all identifiers regardless of use that begin with either
+ two underscores or an underscore followed by a capital letter are reserved names."
+ -- glibc manual, 1.3.3 Reserved Names
+
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ src/help.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/help.h b/src/help.h
+index ae0954b..af7f178 100644
+--- a/src/help.h
++++ b/src/help.h
+@@ -5,8 +5,8 @@
+ * For more information, please visit https://dinisnoise.org/
+ */
+
+-#ifndef __help
+-#define __help
++#ifndef DIN_help
++#define DIN_help
+ #include <string>
+ #include <vector>
+ struct help {
+--
+2.32.0
+