summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-08 14:35:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-08 16:54:57 +0100
commit3ec10b6ac354f7df33a50d3ae5b64e1a4623302e (patch)
treeb5a96fe7d4dbc856a077a036bea0776d7d6b06c2 /media-sound
parentnet-misc/cni-plugins: Version bump to 0.7.4 (diff)
downloadgentoo-3ec10b6ac354f7df33a50d3ae5b64e1a4623302e.tar.gz
gentoo-3ec10b6ac354f7df33a50d3ae5b64e1a4623302e.tar.bz2
gentoo-3ec10b6ac354f7df33a50d3ae5b64e1a4623302e.zip
media-sound/tomahawk: 0.9.0_pre20181030 snapshot bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/tomahawk/Manifest1
-rw-r--r--media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-fix-warning.patch26
-rw-r--r--media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild79
3 files changed, 106 insertions, 0 deletions
diff --git a/media-sound/tomahawk/Manifest b/media-sound/tomahawk/Manifest
index f1955d31d4f8..4f38e703b20d 100644
--- a/media-sound/tomahawk/Manifest
+++ b/media-sound/tomahawk/Manifest
@@ -1 +1,2 @@
DIST tomahawk-0.9.0_pre20180501.tar.gz 9913223 BLAKE2B 430fedf1a06307721d36ce733dc6f380e56ca4ba018816b4d6cf70370a383945033220bded8fef1aaeb0deb49ec89422c4ade6add997d9034620d42c43ba2b8f SHA512 51ee268a7165ee4968cd3fbd883c8e86fdee049dbf85d11ff3212d1648f08557c868c0c3f0f448c3a7fa6a825af4ee94b498b5027a788b545587bf4bae1be1c7
+DIST tomahawk-0.9.0_pre20181030.tar.gz 9875208 BLAKE2B aa0b3955ab0308df5ff4d9fead1106bb26c12594fd958c0d43ff72da4d47de42dc4f96d64f3594828ee6200108b610a600b2b764e09b2e88c8412b22b7d6e605 SHA512 de08dc2873975c4278e36ef01ae516d106edc235ac8cf79dab8cc2338dd47cae3102aa6461c98146ca0ff3c68e1a507168a302a051103482f6636f5cdab97202
diff --git a/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-fix-warning.patch b/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-fix-warning.patch
new file mode 100644
index 000000000000..8e02e8e300c3
--- /dev/null
+++ b/media-sound/tomahawk/files/tomahawk-0.9.0_pre20181030-fix-warning.patch
@@ -0,0 +1,26 @@
+From cd5444573eec73a564263c20220ba0562cc655c5 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 8 Nov 2018 15:10:56 +0100
+Subject: [PATCH] Fix "control reaches end of non-void function" in
+ DelegateConfigWrapper
+
+Thanks-to: Fabian Vogt <fabian@ritter-vogt.de>
+---
+ src/libtomahawk/accounts/DelegateConfigWrapper.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/libtomahawk/accounts/DelegateConfigWrapper.cpp b/src/libtomahawk/accounts/DelegateConfigWrapper.cpp
+index e78b64aec..875016ca1 100644
+--- a/src/libtomahawk/accounts/DelegateConfigWrapper.cpp
++++ b/src/libtomahawk/accounts/DelegateConfigWrapper.cpp
+@@ -247,6 +247,7 @@ DelegateConfigWrapper::getTestConfigMessage( int code )
+ case Tomahawk::Accounts::ConfigTestResultAccountExpired:
+ return tr( "Your account has expired." );
+ }
++ return QString();
+ }
+
+
+--
+2.19.1
+
diff --git a/media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild b/media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild
new file mode 100644
index 000000000000..b9e80fa1ed9e
--- /dev/null
+++ b/media-sound/tomahawk/tomahawk-0.9.0_pre20181030.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=777b31219179b43f56c7b95857d2fbd7f33199aa
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="Multi-source social music player"
+HOMEPAGE="https://www.tomahawk-player.org/"
+SRC_URI="https://github.com/${PN}-player/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="telepathy xmpp"
+
+COMMON_DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ app-crypt/qca:2[qt5(+)]
+ dev-cpp/lucene++
+ dev-cpp/sparsehash
+ dev-libs/boost:=
+ dev-libs/qtkeychain:=[qt5(+)]
+ >=dev-libs/quazip-0.7.2[qt5(+)]
+ kde-frameworks/extra-cmake-modules:5
+ kde-frameworks/attica:5
+ >=media-libs/liblastfm-1.1.0_pre20150206
+ >=media-libs/taglib-1.8.0
+ media-video/vlc:=[flac,dvbpsi,ffmpeg,mp3]
+ >=net-libs/gnutls-3.2:=
+ x11-libs/libX11
+ telepathy? ( >=net-libs/telepathy-qt-0.9.7-r1[qt5(+)] )
+ xmpp? ( >=net-libs/jreen-1.3.0[qt5(+)] )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/designer:5
+ dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+"
+RDEPEND="${COMMON_DEPEND}
+ app-crypt/qca:2[ssl]
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-warning.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_CRASHREPORTER=OFF
+ -DBUILD_TESTS=OFF
+ -DBUILD_TOOLS=OFF
+ -DBUILD_HATCHET=OFF
+ -DWITH_TelepathyQt=$(usex telepathy)
+ -DWITH_Jreen=$(usex xmpp)
+ )
+
+ [[ ${PV} != *9999* ]] && mycmakeargs+=( -DBUILD_RELEASE=ON )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}