summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-02-19 22:35:01 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-02-19 22:35:01 -0600
commitcd0ad782707ace005a44dfa2f05a748cdd817252 (patch)
tree6ea9863cd86fcf7c149e923b836d7792fc421d5c /media-sound
parentdev-python/mccabe: bump EAPI to 6 in vn. 0.4.0 (diff)
downloadgentoo-cd0ad782707ace005a44dfa2f05a748cdd817252.tar.gz
gentoo-cd0ad782707ace005a44dfa2f05a748cdd817252.tar.bz2
gentoo-cd0ad782707ace005a44dfa2f05a748cdd817252.zip
media-sound/spotify: bup
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.23.93.ebuild116
2 files changed, 118 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index 6d6e50b17fd4..b35de9448154 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,4 @@
DIST spotify-client_1.0.19.106.gb8a7150f_amd64.deb 68109944 SHA256 be6b99329bb2fccdc9d77bc949dd463576fdb40db7f56195b4284bd348c470be SHA512 f5d8b5ae860a5e429e14f4541cd9e12e8f7edf864d2a41c2d6acb19af7c00c3f6a813f3666e9bd73f3e0bf1619f63cc03ab9f520d7f0713a036b5cee6a409fea WHIRLPOOL 7d19213e40b85aaf11722a09b8021cdae4ce4a5c8f91e9b5aa5c6a50c1b2862d5bc41c031d486b08141543e2ff4c16b684575e81e8cd6f1cc12b64633aef74ce
DIST spotify-client_1.0.19.106.gb8a7150f_i386.deb 73060616 SHA256 128b5d04dda8a052802fb9e664a996250569696fac359e94ea35043472f5dbcb SHA512 adb5816ceba1e1976429b1985569e1bfaa03fe015904bb3c66676b384205bbe24c3851a9cfcd366124a11470549574086cf289106c0b68e3f124f594b80ff04c WHIRLPOOL ae57091f18c54c2c61252e1bbbffa3228e7621df6dc185bd6821112deec6b78f9a7c269b01d2dd1f595c5751549b8c804732119d8dfd115ddcaee38c977fb4cd
+DIST spotify-client_1.0.23.93.gd6cfae15-30_amd64.deb 75341892 SHA256 99961ccd0b3d01ec28a96e158b4375fed6bb449913d34f6e03429b2d43f9db58 SHA512 746b1324282ab0aa76d8c35519ce4291f05fd061aa6daf6ce5193f3e56566f0dcc3c207016980f4b780e71a55ebd59fb88df2566f538210795278f99b46d80f8 WHIRLPOOL 20e6b8372fdd75adbf95d203e3676c646b8c041de9fa03f8a0fa9b104d5971bef917f764467f148c5dda7e508436bdc7fa35ef158f968e83e7a7c570cd16899a
+DIST spotify-client_1.0.23.93.gd6cfae15-5_i386.deb 78429394 SHA256 e4e8ab10a2a4875632283870155068f7d140b23b5bbb9927f32b53b4002aa6fe SHA512 54b87dcbba33119a9a3c9a01fb899b805096131fd83fcf220148b2064f04ec0d31174b812f2ca53b0e6eacb97440816eb11c8627de44f5b758fbc85aa731c980 WHIRLPOOL dade70b3621db925e54f9f3cc97e621e4338959d86ab218e17e26093f6014fea3346dc57edae3deaeec2f6d162d5fea8b9b60d03f7f5dbeb2a6cfb4e484f22b2
diff --git a/media-sound/spotify/spotify-1.0.23.93.ebuild b/media-sound/spotify/spotify-1.0.23.93.ebuild
new file mode 100644
index 000000000000..5df0c9051df1
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.23.93.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+MY_PV="${PV}.gd6cfae15"
+MY_P="${PN}-client_${MY_PV}"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${MY_P}-30_amd64.deb )
+ x86? ( ${SRC_BASE}${MY_P}-5_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+# zenety needed for filepicker
+RDEPEND="
+ ${DEPEND}
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups[ssl]
+ sys-libs/glibc
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ pulseaudio? ( media-sound/pulseaudio )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.Debian.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}