summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-18 00:19:09 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-18 00:19:17 +0100
commite2db354ce34f3a4fe03c6c98859393a4a6ef0c85 (patch)
treede7a041eec32853d86fddd376c63002cc34f7212 /media-sound
parentdev-ruby/map: Version bump (diff)
downloadgentoo-e2db354ce34f3a4fe03c6c98859393a4a6ef0c85.tar.gz
gentoo-e2db354ce34f3a4fe03c6c98859393a4a6ef0c85.tar.bz2
gentoo-e2db354ce34f3a4fe03c6c98859393a4a6ef0c85.zip
media-sound/lame: add frontend useflag to allow lib only build.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lame/lame-3.99.5-r1.ebuild10
-rw-r--r--media-sound/lame/metadata.xml1
2 files changed, 7 insertions, 4 deletions
diff --git a/media-sound/lame/lame-3.99.5-r1.ebuild b/media-sound/lame/lame-3.99.5-r1.ebuild
index 490e597ae57a..72692e094227 100644
--- a/media-sound/lame/lame-3.99.5-r1.ebuild
+++ b/media-sound/lame/lame-3.99.5-r1.ebuild
@@ -14,13 +14,15 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug cpu_flags_x86_mmx mp3rtp sndfile static-libs"
+IUSE="debug cpu_flags_x86_mmx +frontend mp3rtp sndfile static-libs"
# These deps are without MULTILIB_USEDEP and are correct since we only build
# libmp3lame for multilib and these deps apply to the lame frontend executable.
RDEPEND="
- >=sys-libs/ncurses-5.7-r7:0=
- sndfile? ( >=media-libs/libsndfile-1.0.2 )
+ frontend? (
+ >=sys-libs/ncurses-5.7-r7:0=
+ sndfile? ( >=media-libs/libsndfile-1.0.2 )
+ )
abi_x86_32? ( !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
DEPEND="${RDEPEND}
virtual/pkgconfig
@@ -49,7 +51,7 @@ multilib_src_configure() {
# Only build the frontend for the default ABI.
if [ "${ABI}" = "${DEFAULT_ABI}" ] ; then
- myconf+=" $(use_enable mp3rtp)"
+ myconf+=" $(use_enable mp3rtp) $(use_enable frontend)"
use sndfile && myconf+=" --with-fileio=sndfile"
else
myconf+=" --disable-frontend --disable-mp3rtp"
diff --git a/media-sound/lame/metadata.xml b/media-sound/lame/metadata.xml
index 60f21f1ade8b..433fd3db8ae4 100644
--- a/media-sound/lame/metadata.xml
+++ b/media-sound/lame/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Sound project</name>
</maintainer>
<use>
+ <flag name="frontend">Build and install the 'lame' executable frontend to lame libraries.</flag>
<flag name="mp3rtp">Build the mp3-to-RTP streaming utility. **UNSUPPORTED**</flag>
</use>
<upstream>