summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-09-02 12:41:32 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-09-02 12:43:11 +0100
commitc28ee41c8e7f8c0a4cf37680ce79dfda6b0ef453 (patch)
treedae7b9bbb565bac15698d25fe2b73909f2926d1d /media-tv/tvheadend/tvheadend-9999.ebuild
parentmedia-tv/tvheadend: Version bump to 4.2.6 (diff)
downloadgentoo-c28ee41c8e7f8c0a4cf37680ce79dfda6b0ef453.tar.gz
gentoo-c28ee41c8e7f8c0a4cf37680ce79dfda6b0ef453.tar.bz2
gentoo-c28ee41c8e7f8c0a4cf37680ce79dfda6b0ef453.zip
media-tv/tvheadend: Drop capmt, constcw, cwc USE flags from 9999
These are all served by libdvbcsa with no further dependencies so we might as well put them all behind a common dvbcsa flag. Otherwise we would have had to add yet another flag called cccam. Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'media-tv/tvheadend/tvheadend-9999.ebuild')
-rw-r--r--media-tv/tvheadend/tvheadend-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/media-tv/tvheadend/tvheadend-9999.ebuild b/media-tv/tvheadend/tvheadend-9999.ebuild
index 04ecda4fb1b5..8ee4fdaf1183 100644
--- a/media-tv/tvheadend/tvheadend-9999.ebuild
+++ b/media-tv/tvheadend/tvheadend-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,7 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="+capmt +constcw +cwc dbus debug +ddci dvbcsa +dvb +ffmpeg hdhomerun +imagecache +inotify iptv libressl opus satip systemd +timeshift uriparser vpx x264 x265 xmltv zeroconf zlib"
+IUSE="dbus debug +ddci dvbcsa +dvb +ffmpeg hdhomerun +imagecache +inotify iptv libressl opus satip systemd +timeshift uriparser vpx x264 x265 xmltv zeroconf zlib"
RDEPEND="
virtual/libiconv
@@ -47,7 +47,6 @@ RDEPEND+="
xmltv? ( media-tv/xmltv )"
REQUIRED_USE="
- dvbcsa? ( || ( capmt constcw cwc ) )
ddci? ( dvb )
"
@@ -55,9 +54,9 @@ REQUIRED_USE="
# https://github.com/rpmfusion/tvheadend
PATCHES=(
- "${FILESDIR}/${PN}-4.0.9-use_system_queue.patch"
- "${FILESDIR}/${PN}-4.2.1-hdhomerun.patch"
- "${FILESDIR}/${PN}-4.2.2-dtv_scan_tables.patch"
+ "${FILESDIR}"/${PN}-4.0.9-use_system_queue.patch
+ "${FILESDIR}"/${PN}-4.2.1-hdhomerun.patch
+ "${FILESDIR}"/${PN}-4.2.2-dtv_scan_tables.patch
)
DOCS=( README.md )
@@ -89,14 +88,15 @@ src_configure() {
--enable-libtheora \
--enable-libvorbis \
--nowerror \
- $(use_enable capmt) \
- $(use_enable constcw) \
- $(use_enable cwc) \
$(use_enable dbus dbus_1) \
$(use_enable debug trace) \
$(use_enable ddci) \
$(use_enable dvb linuxdvb) \
$(use_enable dvbcsa) \
+ $(use_enable dvbcsa capmt) \
+ $(use_enable dvbcsa cccam) \
+ $(use_enable dvbcsa constcw) \
+ $(use_enable dvbcsa cwc) \
$(use_enable ffmpeg libav) \
$(use_enable hdhomerun hdhomerun_client) \
$(use_enable imagecache) \