summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/dirac/files/dirac-0.5.2-doc.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/dirac/files/dirac-0.5.2-doc.patch')
-rw-r--r--media-video/dirac/files/dirac-0.5.2-doc.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-video/dirac/files/dirac-0.5.2-doc.patch b/media-video/dirac/files/dirac-0.5.2-doc.patch
new file mode 100644
index 000000000000..211486635dbd
--- /dev/null
+++ b/media-video/dirac/files/dirac-0.5.2-doc.patch
@@ -0,0 +1,59 @@
+diff -x '*~' -ur dirac-0.5.2/configure.ac dirac-0.5.2-doc/configure.ac
+--- dirac-0.5.2/configure.ac 2005-05-20 15:05:25.000000000 +0200
++++ dirac-0.5.2-doc/configure.ac 2005-06-10 03:31:58.683588784 +0200
+@@ -105,28 +105,37 @@
+ dnl -----------------------------------------------
+ dnl Checks for optional programs.
+ dnl -----------------------------------------------
+-AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, true, false)
+- if test $HAVE_DOXYGEN = "false"; then
+- AC_MSG_WARN([*** doxygen not found, code documentation will not be built])
+- fi
+-AM_CONDITIONAL(HAVE_DOXYGEN, $HAVE_DOXYGEN)
++AC_ARG_ENABLE(doc, AC_HELP_STRING([--enable-doc], [enables doc building (no)]), [enabledoc=${enableval}], [enabledoc=no])
+
+-AC_CHECK_PROG(HAVE_DOT, dot, true, false)
+- if test $HAVE_DOT = "false"; then
+- AC_MSG_WARN([*** dot not found, inheritance diagrams will not be generated in code documentation])
++if test "x$enabledoc" != "xno"; then
++ AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, true, false)
++ if test $HAVE_DOXYGEN = "false"; then
++ AC_MSG_WARN([*** doxygen not found, code documentation will not be built])
++ fi
++
++ AC_CHECK_PROG(HAVE_DOT, dot, true, false)
++ if test $HAVE_DOT = "false"; then
++ AC_MSG_WARN([*** dot not found, inheritance diagrams will not be generated in code documentation])
++ fi
++
++ AC_CHECK_PROG(HAVE_LATEX, latex, true, false)
++ if test $HAVE_LATEX = "false"; then
++ AC_MSG_WARN([*** latex not found, algorithm documentation will not be built])
++ fi
++
++ AC_CHECK_PROG(HAVE_DVIPDFM, dvipdfm, true, false)
++ if test $HAVE_DVIPDFM = "false"; then
++ AC_MSG_WARN([*** dvipdfm not found, programmer documentation will not be built])
+ fi
++else
++HAVE_DOXYGEN=false
++HAVE_DOT=false
++HAVE_LATEX=false
++HAVE_DVIPDFM=false
++fi
++AM_CONDITIONAL(HAVE_DOXYGEN, $HAVE_DOXYGEN)
+ AM_CONDITIONAL(HAVE_DOT, $HAVE_DOT)
+-
+-AC_CHECK_PROG(HAVE_LATEX, latex, true, false)
+- if test $HAVE_LATEX = "false"; then
+- AC_MSG_WARN([*** latex not found, algorithm documentation will not be built])
+- fi
+ AM_CONDITIONAL(HAVE_LATEX, $HAVE_LATEX)
+-
+-AC_CHECK_PROG(HAVE_DVIPDFM, dvipdfm, true, false)
+- if test $HAVE_DVIPDFM = "false"; then
+- AC_MSG_WARN([*** dvipdfm not found, programmer documentation will not be built])
+- fi
+ AM_CONDITIONAL(HAVE_DVIPDFM, $HAVE_DVIPDFM)
+
+ AC_ARG_ENABLE(overlay,