summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2022-03-14 11:09:52 +0100
committerSam James <sam@gentoo.org>2022-03-16 22:33:30 +0000
commit6ad2b615f414edd77c02ee9ce9c942687b0aaf70 (patch)
treef2451515321fa0e44b928321e069035a90c5a2ec /media-video/ffmpeg/ffmpeg-9999.ebuild
parentmedia-libs/libvmaf: new package (diff)
downloadgentoo-6ad2b615f414edd77c02ee9ce9c942687b0aaf70.tar.gz
gentoo-6ad2b615f414edd77c02ee9ce9c942687b0aaf70.tar.bz2
gentoo-6ad2b615f414edd77c02ee9ce9c942687b0aaf70.zip
media-video/ffmpeg: enable vmaf use flag
To use Netflix' vmaf scoring algorithm Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Closes: https://github.com/gentoo/gentoo/pull/23412 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index f1ded0aea4a0..1f70d55ec169 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -84,7 +84,7 @@ FFMPEG_FLAG_MAP=(
vorbis:libvorbis vpx:libvpx zvbi:libzvbi
# libavfilter options
appkit
- bs2b:libbs2b chromaprint cuda:cuda-llvm flite:libflite frei0r
+ bs2b:libbs2b chromaprint cuda:cuda-llvm flite:libflite frei0r vmaf:libvmaf
fribidi:libfribidi fontconfig ladspa libass libtesseract lv2 truetype:libfreetype vidstab:libvidstab
rubberband:librubberband zeromq:libzmq zimg:libzimg
# libswresample options
@@ -255,6 +255,7 @@ RDEPEND="
nvenc? ( >=media-libs/nv-codec-headers-9.1.23.1[${MULTILIB_USEDEP}] )
vdpau? ( >=x11-libs/libvdpau-0.7[${MULTILIB_USEDEP}] )
vidstab? ( >=media-libs/vidstab-1.1.0[${MULTILIB_USEDEP}] )
+ vmaf? ( media-libs/libvmaf[${MULTILIB_USEDEP}] )
vorbis? (
>=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}]
>=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
@@ -337,6 +338,9 @@ src_prepare() {
if [[ "${PV%_p*}" != "${PV}" ]] ; then # Snapshot
export revision=git-N-${FFMPEG_REVISION}
fi
+
+ eapply "${FILESDIR}/vmaf-models-default-path.patch"
+
default
echo 'include $(SRC_PATH)/ffbuild/libffmpeg.mak' >> Makefile || die
}