summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-19 16:27:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-19 18:40:58 +0200
commit0637b57d55967a8777e29fbcdee3ab36e4b846f0 (patch)
tree1638e43a3200030f4f031ddbd641aec78c932df2 /media-video/ffmpeg
parentmedia-libs/dav1d: bump to 0.4.0 (diff)
downloadgentoo-0637b57d55967a8777e29fbcdee3ab36e4b846f0.tar.gz
gentoo-0637b57d55967a8777e29fbcdee3ab36e4b846f0.tar.bz2
gentoo-0637b57d55967a8777e29fbcdee3ab36e4b846f0.zip
media-video/ffmpeg: update to eapi7.
Split BDEPEND. Bump dav1d dep. Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 51034ea1e89..748ed934429 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
# Subslot: libavutil major.libavcodec major.libavformat major
# Since FFmpeg ships several libraries, subslot is kind of limited here.
@@ -170,7 +170,7 @@ RDEPEND="
cdio? ( >=dev-libs/libcdio-paranoia-0.90_p1-r1[${MULTILIB_USEDEP}] )
chromaprint? ( >=media-libs/chromaprint-1.2-r1[${MULTILIB_USEDEP}] )
codec2? ( media-libs/codec2[${MULTILIB_USEDEP}] )
- dav1d? ( >=media-libs/dav1d-0.2.1:0=[${MULTILIB_USEDEP}] )
+ dav1d? ( >=media-libs/dav1d-0.4.0:0=[${MULTILIB_USEDEP}] )
encode? (
amrenc? ( >=media-libs/vo-amrwbenc-0.1.2-r1[${MULTILIB_USEDEP}] )
kvazaar? ( >=media-libs/kvazaar-1.2.0[${MULTILIB_USEDEP}] )
@@ -272,13 +272,15 @@ RDEPEND="${RDEPEND}
"
DEPEND="${RDEPEND}
+ ladspa? ( >=media-libs/ladspa-sdk-1.13-r2[${MULTILIB_USEDEP}] )
+ v4l? ( sys-kernel/linux-headers )
+"
+BDEPEND="
>=sys-devel/make-3.81
doc? ( sys-apps/texinfo )
>=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
- ladspa? ( >=media-libs/ladspa-sdk-1.13-r2[${MULTILIB_USEDEP}] )
cpu_flags_x86_mmx? ( || ( >=dev-lang/nasm-2.13 >=dev-lang/yasm-1.3 ) )
test? ( net-misc/wget sys-devel/bc )
- v4l? ( sys-kernel/linux-headers )
"
# Code requiring FFmpeg to be built under gpl license