summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-28 17:30:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-03 16:42:34 +0100
commitefa16741f99b5a0323b43b5d8094ee0b62ac7b26 (patch)
tree58f80841969764bde637d5a75db5db8b17e382cd /media-video/openshot
parentmedia-libs/libopenshot-audio: Drop 0.1.4 (diff)
downloadgentoo-efa16741f99b5a0323b43b5d8094ee0b62ac7b26.tar.gz
gentoo-efa16741f99b5a0323b43b5d8094ee0b62ac7b26.tar.bz2
gentoo-efa16741f99b5a0323b43b5d8094ee0b62ac7b26.zip
media-video/openshot: 2.5.1_p20201203 snapshot bump
Bug: https://bugs.gentoo.org/709858 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/openshot')
-rw-r--r--media-video/openshot/Manifest1
-rw-r--r--media-video/openshot/openshot-2.5.1_p20201203.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/media-video/openshot/Manifest b/media-video/openshot/Manifest
index e7a08b79ef51..f08226a58cba 100644
--- a/media-video/openshot/Manifest
+++ b/media-video/openshot/Manifest
@@ -1,3 +1,4 @@
DIST openshot-2.4.4.tar.gz 63065376 BLAKE2B 2ee00f24d699d5935a182c394821f215a27ba2701d493f51299c19cf99452ca4df2e5b86f7a6e5734e6194e39e5b7995eb94be168c0e9f7bc7a3b78206277304 SHA512 efa71f97a83b89e691b7dab09288ba7d3e91eb25119669fa8f6e28becb8d4cb3e60a923f936ee4ff9a593d016fe3a6b0348153cff937ab7d21a5517de5dfa10c
DIST openshot-2.5.0.tar.gz 60153193 BLAKE2B cdc79c68be7cd5b9e2714c98c4edbb5fc9ec349283da8439e9f9e26b2341688e2b8ae0f108413f59582d6e447faeb96d1da6916503299ca40939d73f5983377f SHA512 0944bff48c8957a4a3c5a37428b4d3e45e8ad6e1664812ea90b7c16d014a3c355daf2fe183ce855586114ccfa36c419b6baacc42c4bf871de29bda4c24f2a814
DIST openshot-2.5.1.tar.gz 60217543 BLAKE2B 3f195b14a9fb004e845c731be64138c20da84ac0c90db43b547ee9ea059d32f85ada04aa0462b755a7ea5c3d3b30088fab35414147dded55deb9d5eab5926d2d SHA512 8254a45254bbe523b6485b9598022de2c46ec30818e606ac4665790d29486693c4efe9f5bc55ee43d6342de6782cf0090e4bc880e831c08e3b1218bca555af14
+DIST openshot-2.5.1_p20201203.tar.gz 64708017 BLAKE2B b95834b8b75460b60a54b2c1efab1752424c291f5e16fefd33671f7ea9eb9c29d48047a18287a9cf2837c21e3c1ea9a7217fcbdc27440bacc04ff6f8da6202a2 SHA512 668c3155489d469042220e059cb0fc4de50b4d949c28d4ae6e8ef9b6ccdd3235dd4912b5163ae4126758621052d4b40f21aa40c6e1682776a71076f0c45cbcdc
diff --git a/media-video/openshot/openshot-2.5.1_p20201203.ebuild b/media-video/openshot/openshot-2.5.1_p20201203.ebuild
new file mode 100644
index 000000000000..53484ce02495
--- /dev/null
+++ b/media-video/openshot/openshot-2.5.1_p20201203.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE=xml
+DISTUTILS_SINGLE_IMPL=1
+
+COMMIT=8c3d90cca72e2051b1b74dc0d731824ed5edf0de
+MY_PN="${PN}-qt"
+inherit distutils-r1 xdg
+
+DESCRIPTION="Award-winning free and open-source video editor"
+HOMEPAGE="https://www.openshot.org/"
+SRC_URI="https://github.com/OpenShot/${MY_PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${COMMIT}"
+
+LICENSE="GPL-3+"
+SLOT="1"
+# KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},gui,svg,widgets]
+ dev-python/PyQtWebEngine[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyzmq[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=media-libs/libopenshot-0.2.5:0=[python,${PYTHON_SINGLE_USEDEP}]
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ doc? ( dev-python/sphinx[${PYTHON_MULTI_USEDEP}] )
+ ')
+"
+
+src_prepare() {
+ distutils-r1_python_prepare_all
+ # prevent setup.py from trying to update MIME databases
+ sed -i 's/^ROOT =.*/ROOT = False/' setup.py || die
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}