summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-09-04 12:15:42 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-09-08 11:04:30 +0200
commit2b82508e7082a8ba0117a9ebe71903006b140ca8 (patch)
treee82e07e0304b88653aa49143936e94f2d5ae182b /media-video/raspberrypi-omxplayer/files/cross-0_p20160528.patch
parentsys-apps/tuned: remove 'sysctl' hardcoded path (diff)
downloadgentoo-2b82508e7082a8ba0117a9ebe71903006b140ca8.tar.gz
gentoo-2b82508e7082a8ba0117a9ebe71903006b140ca8.tar.bz2
gentoo-2b82508e7082a8ba0117a9ebe71903006b140ca8.zip
media-video/raspberrypi-omxplayer: improvements.
* Add cross-compilation support. * EAPI 6 bump. Gentoo-Bug: https://bugs.gentoo.org/590744 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2217 Acked-By: Miroslav Šulc <fordfrog@gentoo.org> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-video/raspberrypi-omxplayer/files/cross-0_p20160528.patch')
-rw-r--r--media-video/raspberrypi-omxplayer/files/cross-0_p20160528.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/media-video/raspberrypi-omxplayer/files/cross-0_p20160528.patch b/media-video/raspberrypi-omxplayer/files/cross-0_p20160528.patch
new file mode 100644
index 000000000000..bd35d6283d21
--- /dev/null
+++ b/media-video/raspberrypi-omxplayer/files/cross-0_p20160528.patch
@@ -0,0 +1,15 @@
+--- a/Makefile
++++ b/Makefile
+@@ -4,9 +4,11 @@
+
+ PKGS=freetype2 dbus-1 libavcodec libavutil libavformat libswresample libswscale libpcre
+
+-LIBS+=-lrt -lpthread $(shell pkg-config --libs $(PKGS)) -L/opt/vc/lib
++PKG_CONFIG ?= pkg-config
+
+-INCLUDES+=$(shell pkg-config --cflags $(PKGS)) -I/opt/vc/include -I. -Ilinux
++LIBS+=-lrt -lpthread $(shell $(PKG_CONFIG) --libs $(PKGS)) -L${SYSROOT}/opt/vc/lib
++
++INCLUDES+=$(shell $(PKG_CONFIG) --cflags $(PKGS)) -I${SYSROOT}/opt/vc/include -I. -Ilinux
+
+ DIST ?= omxplayer-dist