summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2021-09-23 09:46:16 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-09-24 10:55:50 +0300
commit677f24a051b286c5c84f0803f3fabfa4cebec0b9 (patch)
tree9528e85129f7c4f1687d34e993f61463add2123f /media-video/shotcut
parentwww-apps/gitea: Version bump 1.15.2. (diff)
downloadgentoo-677f24a051b286c5c84f0803f3fabfa4cebec0b9.tar.gz
gentoo-677f24a051b286c5c84f0803f3fabfa4cebec0b9.tar.bz2
gentoo-677f24a051b286c5c84f0803f3fabfa4cebec0b9.zip
media-video/shotcut: bump to 21.09.20
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video/shotcut')
-rw-r--r--media-video/shotcut/Manifest1
-rw-r--r--media-video/shotcut/shotcut-21.09.20.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/media-video/shotcut/Manifest b/media-video/shotcut/Manifest
index 86be50d2a7eb..4e70d3aee105 100644
--- a/media-video/shotcut/Manifest
+++ b/media-video/shotcut/Manifest
@@ -1,2 +1,3 @@
DIST shotcut-21.03.21.tar.gz 4101401 BLAKE2B fb716215ba31b4b057080f05a59462a674aebfa364924240f96ebf87bb94e4ccb649c2452e952b507037a8e62840cb7c805ee258761bb21d515173bba26dfdd1 SHA512 402d714df7285d49269891e5def0b8a1a46f54b6ec88b0201981bdf8d866c49e83bbbf513805795630e39335e0fddc2457e1a7db582affe4a4d057ac5ab4e2bb
DIST shotcut-21.06.29.tar.gz 4234142 BLAKE2B 32fa68d07e442fc60301733862d09b8723ff00d49af84a604e5a58c5c4a672c63407387f134b7ffd06a236b55a95c870fcd300d76d0de4a2e864dffef3e54b47 SHA512 b6256b2d6b6f5040321a227e60c447455b9026fc5315ddc0d16fcf76930162552fd883029536de201cb2b58e2544dd58203a4dbc9e27144c4ef399fb53fdb996
+DIST shotcut-21.09.20.tar.gz 4358591 BLAKE2B 3919cb0f5c3f0aaa665729227d077cdeac1569102509bbf6be7f9451cadda8e22b38a8e796ef5fd2f5dd84bff2abbd98103a0917eb9acacdc9db771968f723ef SHA512 6c2463c8d81c4e61b59d97ba2ee8f9aba5c420ee50b6c46c0e5f1c177e44cea6bc1fab5a7184ce8b13d2818b207efffe3c12f4d1682ce002279ba16c1c9bd624
diff --git a/media-video/shotcut/shotcut-21.09.20.ebuild b/media-video/shotcut/shotcut-21.09.20.ebuild
new file mode 100644
index 000000000000..94b278e81817
--- /dev/null
+++ b/media-video/shotcut/shotcut-21.09.20.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="A free, open source, cross-platform video editor"
+HOMEPAGE="https://www.shotcut.org/ https://github.com/mltframework/shotcut/"
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mltframework/shotcut/"
+fi
+
+IUSE="debug"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+COMMON_DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=media-libs/mlt-7.0.1[ffmpeg,frei0r,fftw(+),jack,opengl,qt5,sdl,xml]
+ media-video/ffmpeg
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtx11extras:5
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtquickcontrols:5
+ virtual/jack
+"
+
+src_configure() {
+ local myqmakeargs=(
+ PREFIX="${EPREFIX}/usr"
+ SHOTCUT_VERSION="${PV}"
+ DEFINES+=SHOTCUT_NOUPGRADE
+ )
+ use debug || myqmakeargs+=(DEFINES+=NDEBUG)
+
+ eqmake5 "${myqmakeargs[@]}"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}