summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-13 22:23:26 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-13 23:19:44 -0400
commitfdbb9179c2657bc867f33f5918df8914c787c41a (patch)
treea453cd38af9329b36ad1be27799c309795238b0a /media-video/tcmplex-panteltje/tcmplex-panteltje-0.4.7-r2.ebuild
parentnet-analyzer/labrea: fix build w/ upcoming clang16 (diff)
downloadgentoo-fdbb9179c2657bc867f33f5918df8914c787c41a.tar.gz
gentoo-fdbb9179c2657bc867f33f5918df8914c787c41a.tar.bz2
gentoo-fdbb9179c2657bc867f33f5918df8914c787c41a.zip
media-video/tcmplex-panteltje: EAPI6->8, fix direct CC, clang16
Also: * pass -std=gnu89 (broken with clang -std=c2x) * add CPPFLAGS to the old sed * GPL-2 -> GPL-2+ Closes: https://bugs.gentoo.org/724824 Closes: https://bugs.gentoo.org/871534 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-video/tcmplex-panteltje/tcmplex-panteltje-0.4.7-r2.ebuild')
-rw-r--r--media-video/tcmplex-panteltje/tcmplex-panteltje-0.4.7-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-video/tcmplex-panteltje/tcmplex-panteltje-0.4.7-r2.ebuild b/media-video/tcmplex-panteltje/tcmplex-panteltje-0.4.7-r2.ebuild
new file mode 100644
index 000000000000..d2ee480f2230
--- /dev/null
+++ b/media-video/tcmplex-panteltje/tcmplex-panteltje-0.4.7-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Audio video multiplexer for 8 audio channels"
+HOMEPAGE="http://panteltje.com/panteltje/dvd/"
+SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "s:CFLAGS = -O2:CFLAGS += \$(CPPFLAGS):" \
+ -e "s:\$(LIBRARY):\$(LIBRARY) \$(LDFLAGS):" \
+ -i Makefile || die
+}
+
+src_compile() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin tcmplex-panteltje
+ einstalldocs
+}