summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-02-29 14:09:31 +0100
committerLouis Sautier <sautier.louis@gmail.com>2016-02-29 17:18:11 +0100
commit552e112547c9bed614cd69260d60d09a02922ef0 (patch)
tree59cbdc44f1fff53b43cd793f2b03254b353a7311 /media-video
parentx11-plugins/wmmsg: fix imlib2[X] dependency (diff)
downloadgentoo-552e112547c9bed614cd69260d60d09a02922ef0.tar.gz
gentoo-552e112547c9bed614cd69260d60d09a02922ef0.tar.bz2
gentoo-552e112547c9bed614cd69260d60d09a02922ef0.zip
media-video/bdsup2sub++: new package, C++ port of BDSup2Sub
Package-Manager: portage-2.2.27
Diffstat (limited to 'media-video')
-rw-r--r--media-video/bdsup2sub++/Manifest1
-rw-r--r--media-video/bdsup2sub++/bdsup2sub++-1.0.2.ebuild33
-rw-r--r--media-video/bdsup2sub++/metadata.xml20
3 files changed, 54 insertions, 0 deletions
diff --git a/media-video/bdsup2sub++/Manifest b/media-video/bdsup2sub++/Manifest
new file mode 100644
index 000000000000..f5d3a0f6a97f
--- /dev/null
+++ b/media-video/bdsup2sub++/Manifest
@@ -0,0 +1 @@
+DIST bdsup2sub++-1.0.2.tar.gz 301413 SHA256 89b1a99313fe2f1a3ff101c64a2f85e7f92c81fde41a212a3d854caf49b933c5 SHA512 181cd241588d0fe9217b4534c377af745ff04bcf1af5fbff44c821ec8e45063bb5df0bef0b5d8ba6a9f24740387959487c6e2d3964bfefd935a098ad525b8102 WHIRLPOOL b5a81ea1bfca02bc8ecf7fb35f47fd9507bd3b078bfd7241bd9ae176e7c7acf97c9478654f1c1e50b9ee1474d14b6c63d7184e1b66d9b432f0f44f771570c0e6
diff --git a/media-video/bdsup2sub++/bdsup2sub++-1.0.2.ebuild b/media-video/bdsup2sub++/bdsup2sub++-1.0.2.ebuild
new file mode 100644
index 000000000000..de59e6869786
--- /dev/null
+++ b/media-video/bdsup2sub++/bdsup2sub++-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils
+
+MY_PN="BDSup2SubPlusPlus"
+DESCRIPTION="C++ port of BDSup2Sub"
+HOMEPAGE="https://github.com/amichaelt/BDSup2SubPlusPlus"
+SRC_URI="https://github.com/amichaelt/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/libqxt
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}/src"
+
+src_configure() {
+ eqmake4 ${PN}.pro
+}
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/media-video/bdsup2sub++/metadata.xml b/media-video/bdsup2sub++/metadata.xml
new file mode 100644
index 000000000000..d02dde92d43c
--- /dev/null
+++ b/media-video/bdsup2sub++/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">amichaelt/BDSup2SubPlusPlus</remote-id>
+ <bugs-to>https://github.com/amichaelt/BDSup2SubPlusPlus/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ BDSup2Sub++ (c) 2012 is a port of the original BDSup2Sub (c) 2009 by 0xdeadbeef and incorporating enhancements from Miklos Juhasz. It is a subtitle conversion tool for image based stream formats with scaling capabilities and some other nice features.
+ </longdescription>
+</pkgmetadata>