summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/arpon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/arpon')
-rw-r--r--net-analyzer/arpon/Manifest2
-rw-r--r--net-analyzer/arpon/arpon-2.7-r1.ebuild40
-rw-r--r--net-analyzer/arpon/arpon-2.7.2.ebuild40
-rw-r--r--net-analyzer/arpon/files/arpon.confd5
-rw-r--r--net-analyzer/arpon/files/arpon.initd19
-rw-r--r--net-analyzer/arpon/metadata.xml13
6 files changed, 119 insertions, 0 deletions
diff --git a/net-analyzer/arpon/Manifest b/net-analyzer/arpon/Manifest
new file mode 100644
index 000000000000..304f62ce42da
--- /dev/null
+++ b/net-analyzer/arpon/Manifest
@@ -0,0 +1,2 @@
+DIST ArpON-2.7.2.tar.gz 2780607 SHA256 99adf83e4cdf2eda01601a60e2e1a611b5bce73865745fe67774c525c5f7d6d0 SHA512 7518f8f8920817725c9b3e0a6420190dcc101b1c0c7cd9eec50870b3f893fe2322eddc90cb71e9c3c35326b4e1730aa02797ca51775caa9401807da3978628b4 WHIRLPOOL a164419425ad55d35ebb2bea17cedb4d834b99a17deb0c5a46d39b047cc937113359c39c5b6e1d156daecf3490a9dbf29eeff06c22c4dd2020ffcac00552cc00
+DIST ArpON-2.7.tar.gz 3009833 SHA256 6ad51204bc33cf004c493f62d7ab24d83213c1621b00efc540e30a0c9fe3db94 SHA512 472261bd23c61cd6a5caabe02c95d8749b488b84177fdcd5d35bb19414a3a547ff9f7b722f8e9fb1cb59a1d6d358de4a560459e9c037aa247e7a97df0d49ecb8 WHIRLPOOL a0259e91c3b91942c6f8e5b497404d7a753e957b79643f9ce7444fe8f3dfb7673827be2986aeb32ed0485b1dad047a864ea3faedc732d85bd0ea7a69326a4a0f
diff --git a/net-analyzer/arpon/arpon-2.7-r1.ebuild b/net-analyzer/arpon/arpon-2.7-r1.ebuild
new file mode 100644
index 000000000000..7b44475b469c
--- /dev/null
+++ b/net-analyzer/arpon/arpon-2.7-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit cmake-utils readme.gentoo
+
+DESCRIPTION="ArpON (Arp handler inspectiON) is a portable Arp handler"
+
+MY_PN="ArpON"
+MY_P="${MY_PN}-${PV}"
+HOMEPAGE="http://arpon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/libdnet
+ net-libs/libnet:1.1
+ net-libs/libpcap"
+
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ sed -i -e "/set(CMAKE_C_FLAGS/d" CMakeLists.txt || die
+
+ DOC_CONTENTS="${PN} now installs an init script. Please edit
+ the /etc/conf.d/arpon file to match your needs"
+}
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ readme.gentoo_create_doc
+}
diff --git a/net-analyzer/arpon/arpon-2.7.2.ebuild b/net-analyzer/arpon/arpon-2.7.2.ebuild
new file mode 100644
index 000000000000..ed65ce249075
--- /dev/null
+++ b/net-analyzer/arpon/arpon-2.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit cmake-utils readme.gentoo
+
+DESCRIPTION="ArpON (Arp handler inspectiON) is a portable Arp handler"
+
+MY_PN="ArpON"
+MY_P="${MY_PN}-${PV}"
+HOMEPAGE="http://arpon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libdnet
+ net-libs/libnet:1.1
+ net-libs/libpcap"
+
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ sed -i -e "/set(CMAKE_C_FLAGS/d" CMakeLists.txt || die
+
+ DOC_CONTENTS="${PN} now installs an init script. Please edit
+ the /etc/conf.d/arpon file to match your needs"
+}
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ readme.gentoo_create_doc
+}
diff --git a/net-analyzer/arpon/files/arpon.confd b/net-analyzer/arpon/files/arpon.confd
new file mode 100644
index 000000000000..d1ce050fa4cb
--- /dev/null
+++ b/net-analyzer/arpon/files/arpon.confd
@@ -0,0 +1,5 @@
+METHOD="--darpi"
+IFACE="eth0"
+LOGFILE="/var/log/arpon.log"
+
+ARPON_OPTS="${METHOD} --iface ${IFACE} --log-file ${LOGFILE} --log"
diff --git a/net-analyzer/arpon/files/arpon.initd b/net-analyzer/arpon/files/arpon.initd
new file mode 100644
index 000000000000..5f6a1bd8c6e2
--- /dev/null
+++ b/net-analyzer/arpon/files/arpon.initd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting arpon"
+ start-stop-daemon --start --background --make-pidfile --pidfile "/var/run/arpon.pid" \
+ --exec /usr/sbin/arpon -- ${ARPON_OPTS} >/dev/null 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping arpon"
+ start-stop-daemon --stop --pidfile "/var/run/arpon.pid"
+ eend $?
+}
diff --git a/net-analyzer/arpon/metadata.xml b/net-analyzer/arpon/metadata.xml
new file mode 100644
index 000000000000..ea4208c346e9
--- /dev/null
+++ b/net-analyzer/arpon/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">arpon</remote-id>
+ </upstream>
+</pkgmetadata>