summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2024-07-27 16:04:13 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-07-28 19:39:58 +0200
commit9566373b00852e21cdd88b338684ad4a074f4e00 (patch)
tree4dc633a92d0c1646f0657ecb9ffe65bf0e4a0e06 /net-analyzer/boreas/files
parentjava-utils-2.eclass: select java-config binary, prefer java-config over java-... (diff)
downloadgentoo-9566373b00852e21cdd88b338684ad4a074f4e00.tar.gz
gentoo-9566373b00852e21cdd88b338684ad4a074f4e00.tar.bz2
gentoo-9566373b00852e21cdd88b338684ad4a074f4e00.zip
net-analyzer/boreas: new package, add 22.5.0
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer/boreas/files')
-rw-r--r--net-analyzer/boreas/files/boreas-22.5.0-fix-leading-withespaces-ldflags-libpcap.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/net-analyzer/boreas/files/boreas-22.5.0-fix-leading-withespaces-ldflags-libpcap.patch b/net-analyzer/boreas/files/boreas-22.5.0-fix-leading-withespaces-ldflags-libpcap.patch
new file mode 100644
index 000000000000..9196531765fe
--- /dev/null
+++ b/net-analyzer/boreas/files/boreas-22.5.0-fix-leading-withespaces-ldflags-libpcap.patch
@@ -0,0 +1,14 @@
+Fixes leading withespaces in LDFLAGS for libpcap
+From: Giuseppe Foti <foti.giuseppe@gmail.com>
+Upstream PR: https://github.com/greenbone/boreas/pull/66
+
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -32,6 +32,7 @@ if (PCAP_CONFIG)
+ execute_process (COMMAND pcap-config --libs
+ OUTPUT_VARIABLE PCAP_LDFLAGS
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
++ string(STRIP ${PCAP_LDFLAGS} PCAP_LDFLAGS)
+ execute_process (COMMAND pcap-config --cflags
+ OUTPUT_VARIABLE PCAP_CFLAGS
+ OUTPUT_STRIP_TRAILING_WHITESPACE)