summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-16 17:47:54 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-16 17:48:28 +0200
commitd57c699afeb1df34ac362f360473ea81258df3ab (patch)
treed4ab3a4786498d4760e38716d7eb1a5ec39cce5c /net-analyzer/dsniff/files
parentnet-libs/libnsl: Write the deps differently (diff)
downloadgentoo-d57c699afeb1df34ac362f360473ea81258df3ab.tar.gz
gentoo-d57c699afeb1df34ac362f360473ea81258df3ab.tar.bz2
gentoo-d57c699afeb1df34ac362f360473ea81258df3ab.zip
net-analyzer/dsniff: Fix build against glibc-2.26, bug 370645
The autotools patch does the absolute minimum for a successful build; more elegant solutions are certainly possible. Buildtested against glibc-2.25 (with included rpc support) and glibc-2.26 (without). Closes: https://bugs.gentoo.org/370645 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-analyzer/dsniff/files')
-rw-r--r--net-analyzer/dsniff/files/2.4_beta1-libtirpc.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-analyzer/dsniff/files/2.4_beta1-libtirpc.patch b/net-analyzer/dsniff/files/2.4_beta1-libtirpc.patch
new file mode 100644
index 000000000000..5f8b1169d217
--- /dev/null
+++ b/net-analyzer/dsniff/files/2.4_beta1-libtirpc.patch
@@ -0,0 +1,24 @@
+diff -ruN dsniff-2.4.orig/Makefile.in dsniff-2.4/Makefile.in
+--- dsniff-2.4.orig/Makefile.in 2017-09-16 12:20:13.001953108 -0000
++++ dsniff-2.4/Makefile.in 2017-09-16 12:37:32.452792454 -0000
+@@ -37,8 +37,8 @@
+ X11INC = @X_CFLAGS@
+ X11LIB = @X_LIBS@ @X_PRE_LIBS@ -lXmu -lX11 @X_EXTRA_LIBS@
+
+-INCS = -I. $(X11INC) -I$(srcdir)/missing
+-LIBS = @LIBS@ -L$(srcdir) -lmissing
++INCS = -I. $(X11INC) -I$(srcdir)/missing @TIRPC_CFLAGS@
++LIBS = @LIBS@ -L$(srcdir) -lmissing @TIRPC_LIBS@
+
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+diff -ruN dsniff-2.4.orig/configure.in dsniff-2.4/configure.in
+--- dsniff-2.4.orig/configure.in 2017-09-16 12:20:07.346916686 -0000
++++ dsniff-2.4/configure.in 2017-09-16 12:33:42.559167188 -0000
+@@ -338,4 +338,6 @@
+ AC_SUBST(SSLINC)
+ AC_SUBST(SSLLIB)
+
++PKG_CHECK_MODULES([TIRPC], [libtirpc], [], [AC_MSG_NOTICE([Using glibc rpc support])])
++
+ AC_OUTPUT(Makefile)