summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-12 10:01:05 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-12 10:01:40 +0100
commit6d850269d2f8f32e37c778e45caaba8273d9eb7f (patch)
tree90a1e6e6f3d92400b48eb3052ca2fb027bec6d49 /net-analyzer/fail2ban
parentdev-ruby/rspec-core: cleanup (diff)
downloadgentoo-6d850269d2f8f32e37c778e45caaba8273d9eb7f.tar.gz
gentoo-6d850269d2f8f32e37c778e45caaba8273d9eb7f.tar.bz2
gentoo-6d850269d2f8f32e37c778e45caaba8273d9eb7f.zip
net-analyzer/fail2ban: Install bashcomp file
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Closes: https://bugs.gentoo.org/705176 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/fail2ban')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.10.5-r1.ebuild (renamed from net-analyzer/fail2ban/fail2ban-0.10.5.ebuild)5
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.11.1-r1.ebuild (renamed from net-analyzer/fail2ban/fail2ban-0.11.1.ebuild)5
-rw-r--r--net-analyzer/fail2ban/fail2ban-99999999.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.10.5.ebuild b/net-analyzer/fail2ban/fail2ban-0.10.5-r1.ebuild
index 85730ff0b684..56a0f3046d23 100644
--- a/net-analyzer/fail2ban/fail2ban-0.10.5.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.10.5-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{2_7,3_6} )
DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 systemd
+inherit bash-completion-r1 distutils-r1 systemd
DESCRIPTION="scans log files and bans IPs that show malicious signs"
HOMEPAGE="https://www.fail2ban.org/"
@@ -72,6 +72,9 @@ python_install_all() {
newins files/${PN}-logrotate ${PN}
keepdir /var/lib/${PN}
+
+ newbashcomp files/bash-completion ${PN}-client
+ bashcomp_alias ${PN}-client ${PN}-server ${PN}-regex
}
pkg_preinst() {
diff --git a/net-analyzer/fail2ban/fail2ban-0.11.1.ebuild b/net-analyzer/fail2ban/fail2ban-0.11.1-r1.ebuild
index 2b9834eff16a..8481a7ca53ff 100644
--- a/net-analyzer/fail2ban/fail2ban-0.11.1.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.11.1-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{2_7,3_6} )
DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 systemd
+inherit bash-completion-r1 distutils-r1 systemd
DESCRIPTION="scans log files and bans IPs that show malicious signs"
HOMEPAGE="https://www.fail2ban.org/"
@@ -67,6 +67,9 @@ python_install_all() {
newins files/${PN}-logrotate ${PN}
keepdir /var/lib/${PN}
+
+ newbashcomp files/bash-completion ${PN}-client
+ bashcomp_alias ${PN}-client ${PN}-server ${PN}-regex
}
pkg_preinst() {
diff --git a/net-analyzer/fail2ban/fail2ban-99999999.ebuild b/net-analyzer/fail2ban/fail2ban-99999999.ebuild
index 59fb036b1675..1618b1f20e24 100644
--- a/net-analyzer/fail2ban/fail2ban-99999999.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-99999999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{2_7,3_6} )
DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 git-r3 systemd
+inherit bash-completion-r1 distutils-r1 git-r3 systemd
DESCRIPTION="scans log files and bans IPs that show malicious signs"
HOMEPAGE="https://www.fail2ban.org/"
@@ -67,6 +67,9 @@ python_install_all() {
newins files/${PN}-logrotate ${PN}
keepdir /var/lib/${PN}
+
+ newbashcomp files/bash-completion ${PN}-client
+ bashcomp_alias ${PN}-client ${PN}-server ${PN}-regex
}
pkg_preinst() {