summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/fwlogwatch/fwlogwatch-1.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/fwlogwatch/fwlogwatch-1.4.ebuild')
-rw-r--r--net-analyzer/fwlogwatch/fwlogwatch-1.4.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/net-analyzer/fwlogwatch/fwlogwatch-1.4.ebuild b/net-analyzer/fwlogwatch/fwlogwatch-1.4.ebuild
new file mode 100644
index 000000000000..97901599e1aa
--- /dev/null
+++ b/net-analyzer/fwlogwatch/fwlogwatch-1.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A packet filter and firewall log analyzer"
+HOMEPAGE="http://fwlogwatch.inside-security.de/"
+SRC_URI="${HOMEPAGE}sw/${P}.tar.bz2"
+
+KEYWORDS="amd64 ~ppc sparc x86"
+LICENSE="GPL-1"
+SLOT="0"
+IUSE="nls zlib"
+
+RDEPEND="
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ if use nls; then
+ strip-linguas -i po/
+ local lingua pofile
+ for pofile in po/*.po; do
+ lingua=${pofile/po\/}
+ lingua=${lingua/.po}
+ if ! has ${lingua} ${LINGUAS}; then
+ sed -i \
+ -e "/${lingua}.[mp]o/d" \
+ Makefile po/Makefile || die
+ fi
+ done
+ fi
+
+ sed -i \
+ -e '/^INSTALL_/s|$| -D|g' \
+ -e 's|make|$(MAKE)|g ' \
+ Makefile || die
+}
+
+src_configure() {
+ if ! use zlib; then
+ sed -i Makefile -e '/^LIBS/ s|-lz||g' || die
+ else
+ append-cflags -DHAVE_ZLIB
+ fi
+
+ use nls && append-cflags -DHAVE_GETTEXT
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+ use nls && emake -C po
+}
+
+src_install() {
+ emake \
+ LOCALE_DIR="${D}/usr" INSTALL_DIR="${D}/usr" \
+ install
+ use nls && emake \
+ LOCALE_DIR="${D}/usr" INSTALL_DIR="${D}/usr" \
+ install-i18n
+
+ dosbin contrib/fwlw_notify
+ dosbin contrib/fwlw_respond
+
+ dodoc AUTHORS ChangeLog CREDITS README
+
+ insinto /usr/share/fwlogwatch/contrib
+
+ doins contrib/fwlogsummary.cgi
+ doins contrib/fwlogsummary_small.cgi
+ doins contrib/fwlogwatch.php
+
+ insinto /etc
+ doins fwlogwatch.config
+}