summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-07 10:11:25 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-07 10:11:25 -0700
commite01a20b8121bb88979dfd4a4d2a8532b4ae3c045 (patch)
tree53dc9e557339242af6ec7c7aaf5f1ee330809b87 /net-analyzer/gnome-nettool
parentapp-editors/ghex: Prevent parallel installation (diff)
downloadgentoo-e01a20b8121bb88979dfd4a4d2a8532b4ae3c045.tar.gz
gentoo-e01a20b8121bb88979dfd4a4d2a8532b4ae3c045.tar.bz2
gentoo-e01a20b8121bb88979dfd4a4d2a8532b4ae3c045.zip
net-analyzer/gnome-nettool: Update icon cache
Closes: https://bugs.gentoo.org/837005 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-analyzer/gnome-nettool')
-rw-r--r--net-analyzer/gnome-nettool/gnome-nettool-42.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/net-analyzer/gnome-nettool/gnome-nettool-42.0.ebuild b/net-analyzer/gnome-nettool/gnome-nettool-42.0.ebuild
index d1128c1f4e5f..0237bc3c236d 100644
--- a/net-analyzer/gnome-nettool/gnome-nettool-42.0.ebuild
+++ b/net-analyzer/gnome-nettool/gnome-nettool-42.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit gnome.org meson python-any-r1
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
DESCRIPTION="Graphical front-ends to various networking command-line"
HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-nettool"
@@ -39,3 +39,13 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PV}-meson-drop-unused-positional-arguments.patch
)
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}