summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-06-29 07:44:20 +0200
committerJeroen Roovers <jer@gentoo.org>2018-06-29 07:44:49 +0200
commitfbac8c974a7b0b0d017e3cc9a676a0f3ea88981d (patch)
treebc0166d2e7734e5c054e3dd2807361108472a024 /net-analyzer/gnu-netcat
parentapp-emulation/qemu-guest-agent: disable tools (diff)
downloadgentoo-fbac8c974a7b0b0d017e3cc9a676a0f3ea88981d.tar.gz
gentoo-fbac8c974a7b0b0d017e3cc9a676a0f3ea88981d.tar.bz2
gentoo-fbac8c974a7b0b0d017e3cc9a676a0f3ea88981d.zip
net-analyzer/gnu-netcat: EAPI bump.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'net-analyzer/gnu-netcat')
-rw-r--r--net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r4.ebuild b/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r4.ebuild
new file mode 100644
index 000000000000..f71fcffaaa0b
--- /dev/null
+++ b/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="the GNU network swiss army knife"
+HOMEPAGE="http://netcat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/netcat/netcat-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug nls"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-LC_CTYPE.patch
+ "${FILESDIR}"/${PN}-close.patch
+ "${FILESDIR}"/${PN}-flagcount.patch
+)
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+S=${WORKDIR}/netcat-${PV}
+
+src_configure() {
+ use debug && append-flags -DDEBUG
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+ rm "${ED}"usr/bin/nc || die
+}