summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-05-02 11:25:08 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-02 13:16:38 +0200
commitfaa039835c7c59bc8153d32aabed62c5ed5a50b7 (patch)
tree78d810df964ead87a6452ff75d199be746f16043 /net-analyzer/gvm-tools
parentnet-analyzer/python-gvm: add 21.11.0 (diff)
downloadgentoo-faa039835c7c59bc8153d32aabed62c5ed5a50b7.tar.gz
gentoo-faa039835c7c59bc8153d32aabed62c5ed5a50b7.tar.bz2
gentoo-faa039835c7c59bc8153d32aabed62c5ed5a50b7.zip
net-analyzer/gvm-tools: add 21.10.0
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer/gvm-tools')
-rw-r--r--net-analyzer/gvm-tools/Manifest1
-rw-r--r--net-analyzer/gvm-tools/gvm-tools-21.10.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/gvm-tools/Manifest b/net-analyzer/gvm-tools/Manifest
index 0d1e3086dfdc..ef527c9a7371 100644
--- a/net-analyzer/gvm-tools/Manifest
+++ b/net-analyzer/gvm-tools/Manifest
@@ -1,3 +1,4 @@
DIST gvm-tools-2.0.0.tar.gz 114592 BLAKE2B 73532138f4153ce625e68d4feb477bea4504be910266d6dac113caff1da096bc6072649ddc456b3348e1aba79c9b7e147ba019a70e4163267c474850019a076e SHA512 0adf7e06b1208c91fbc02dab42593280c95f6572e27d96d6f8777d710747a9e427c79678d9aef785b7ecd6d4fd30e79a1c063fe4256025ac0616c1d242f45025
DIST gvm-tools-2.1.0.tar.gz 128144 BLAKE2B d9dd1857446912bd26a0b5efa38cc34c77bfe9959aaa9ab42ea8518ef9231e5877317319ac8e924b14a5382c80cb00c70d0413635506355eb111b84b5715bf4e SHA512 80933ab8303c1ff77451a9fafd9331b6a0b4c3ae40c4ea318171b6b9e969fb6f20c6970d021a14db1bf8ff816c7f779e2eb750bf84f9093055273f58ad04cda2
DIST gvm-tools-21.1.0.tar.gz 147382 BLAKE2B e7e4bd2e552d07790a21df5eba8370a0b7ae38e2960a53ece98572ac17b258cf7d74e0f1c0fd53382d9b97f18a43bcc6acecbdf861ea871602d72cfeb3c0b407 SHA512 4a02d84045642d018a52e0a17d9a4b683108e1140c512daed48403e56e996dd2487ffe914bc2fbf454c244c51500cff5a934e43feee18f76088ba1912ef84c3f
+DIST gvm-tools-21.10.0.tar.gz 162620 BLAKE2B b205fad4ef05dbd7f8d01b92cf8c123145cb526320dbe881b82ae53ebfbe5e1ee5858996687e256540dd9ce66a8fa50937b6bc0b79888c2c43389db107cefcb0 SHA512 0dc202debaae1431194585575d11b1af6aa057456429dc46e7bf6677b2217fd8569572dc71b8ada578caa961ff2b371a364fb67277c40e76e3025b6b3fcb3a5b
diff --git a/net-analyzer/gvm-tools/gvm-tools-21.10.0.ebuild b/net-analyzer/gvm-tools/gvm-tools-21.10.0.ebuild
new file mode 100644
index 000000000000..5577eb4050d5
--- /dev/null
+++ b/net-analyzer/gvm-tools/gvm-tools-21.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Remote control for Greenbone Vulnerability Manager, previously named openvas-cli"
+HOMEPAGE="https://www.greenbone.net/en/ https://github.com/greenbone/gvm-tools/"
+SRC_URI="https://github.com/greenbone/gvm-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=net-analyzer/python-gvm-21.11.0[${PYTHON_USEDEP}]
+ !net-analyzer/openvas-cli
+ !net-analyzer/openvas-tools"
+
+DEPEND="
+ ${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Fixing tests
+ # Use correct socket path
+ sed -i "s/\/usr\/local\/var\/run\/gvmd.sock/\/var\/run\/gvmd.sock/g" tests/test_parser.py || die
+ # ignore help formating
+ sed -i "s/class HelpFormatting/@unittest.skip('ignoring help formatting')\nclass HelpFormatting/g" tests/test_parser.py || die
+}