summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ifmetric
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ifmetric')
-rw-r--r--net-analyzer/ifmetric/Manifest1
-rw-r--r--net-analyzer/ifmetric/files/ifmetric-0.3-ul.patch11
-rw-r--r--net-analyzer/ifmetric/ifmetric-0.3-r1.ebuild34
-rw-r--r--net-analyzer/ifmetric/ifmetric-0.3.ebuild32
-rw-r--r--net-analyzer/ifmetric/metadata.xml5
5 files changed, 83 insertions, 0 deletions
diff --git a/net-analyzer/ifmetric/Manifest b/net-analyzer/ifmetric/Manifest
new file mode 100644
index 000000000000..90231ad2e6f3
--- /dev/null
+++ b/net-analyzer/ifmetric/Manifest
@@ -0,0 +1 @@
+DIST ifmetric-0.3.tar.gz 81502 SHA256 0fa8510a4e34e555f136f9df81d26618313f2d69a4880c0fb5967f19502f1aec SHA512 301d6bc1c97a59597fe55d81a04c1b654aee24d12ac10201ab56cf23b5164808270f15c142cc49142787db70b400cc18b96561aefcf212111ba47df28f07aa95 WHIRLPOOL 66e79bed3ed472d4fddd46a96d4fa60c4cb733481a610fa442aa686fbd9c5d1f3726e3bff9aafed7e5617007e829d096c5a001740c0cb687e4231a46a8854adf
diff --git a/net-analyzer/ifmetric/files/ifmetric-0.3-ul.patch b/net-analyzer/ifmetric/files/ifmetric-0.3-ul.patch
new file mode 100644
index 000000000000..eb432dc29c0e
--- /dev/null
+++ b/net-analyzer/ifmetric/files/ifmetric-0.3-ul.patch
@@ -0,0 +1,11 @@
+--- a/src/nlrequest.c
++++ b/src/nlrequest.c
+@@ -56,7 +56,7 @@
+ int ret;
+
+ if (!NLMSG_OK(p, bytes) || bytes < sizeof(struct nlmsghdr) || bytes < p->nlmsg_len) {
+- fprintf(stderr, "NETLINK: Packet too small or truncated! %u!=%u!=%u\n", bytes, sizeof(struct nlmsghdr), p->nlmsg_len);
++ fprintf(stderr, "NETLINK: Packet too small or truncated! %u!=%lu!=%u\n", bytes, sizeof(struct nlmsghdr), p->nlmsg_len);
+ return -1;
+ }
+
diff --git a/net-analyzer/ifmetric/ifmetric-0.3-r1.ebuild b/net-analyzer/ifmetric/ifmetric-0.3-r1.ebuild
new file mode 100644
index 000000000000..51d845bb2902
--- /dev/null
+++ b/net-analyzer/ifmetric/ifmetric-0.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Linux tool for setting metrics of all IPv4 routes attached to a given network interface at once"
+HOMEPAGE="http://0pointer.de/lennart/projects/ifmetric/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="sys-kernel/linux-headers"
+
+DOCS=( README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ul.patch
+}
+
+src_configure() {
+ # man page and HTML are already generated
+ econf \
+ --disable-xmltoman \
+ --disable-lynx
+}
+
+src_install() {
+ default
+ dohtml doc/README.html
+}
diff --git a/net-analyzer/ifmetric/ifmetric-0.3.ebuild b/net-analyzer/ifmetric/ifmetric-0.3.ebuild
new file mode 100644
index 000000000000..8ddcc25e0763
--- /dev/null
+++ b/net-analyzer/ifmetric/ifmetric-0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Linux tool for setting metrics of all IPv4 routes attached to a given network interface at once"
+HOMEPAGE="http://0pointer.de/lennart/projects/ifmetric/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+# NOTE: this app is linux-only, virtual/os-headers therefore is incorrect
+DEPEND="sys-kernel/linux-headers"
+RDEPEND=""
+
+DOCS=( README )
+
+src_configure() {
+ # man page and HTML are already generated
+ econf \
+ --disable-xmltoman \
+ --disable-lynx
+}
+
+src_install() {
+ default
+ dohtml doc/README.html
+}
diff --git a/net-analyzer/ifmetric/metadata.xml b/net-analyzer/ifmetric/metadata.xml
new file mode 100644
index 000000000000..78692635ad22
--- /dev/null
+++ b/net-analyzer/ifmetric/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+</pkgmetadata>