summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-10-11 11:53:58 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-15 23:11:16 +0200
commit3daf4a7b1c4e485e0679b4abdd7cead0ee3f9a45 (patch)
tree7697272fab548ca56e54e4ee05c82cd81843bf42 /net-analyzer/linkchecker
parentnet-misc/remmina: version bump to 1.2.0_rc21. (diff)
downloadgentoo-3daf4a7b1c4e485e0679b4abdd7cead0ee3f9a45.tar.gz
gentoo-3daf4a7b1c4e485e0679b4abdd7cead0ee3f9a45.tar.bz2
gentoo-3daf4a7b1c4e485e0679b4abdd7cead0ee3f9a45.zip
net-analyzer/linkchecker: version bump to 9.3.1.
Package-Manager: Portage-2.3.10, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5916
Diffstat (limited to 'net-analyzer/linkchecker')
-rw-r--r--net-analyzer/linkchecker/Manifest1
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-9.3.1-build-fix.patch14
-rw-r--r--net-analyzer/linkchecker/linkchecker-9.3-r2.ebuild2
-rw-r--r--net-analyzer/linkchecker/linkchecker-9.3.1.ebuild75
4 files changed, 91 insertions, 1 deletions
diff --git a/net-analyzer/linkchecker/Manifest b/net-analyzer/linkchecker/Manifest
index 05bbc69fa0d3..773d88e95e5d 100644
--- a/net-analyzer/linkchecker/Manifest
+++ b/net-analyzer/linkchecker/Manifest
@@ -1 +1,2 @@
DIST LinkChecker-9.3.tar.gz 719896 SHA256 ee0aa60de440fdcf8587ddebf1f691bc777a32d8d4f119beed63f405dc56176d SHA512 26686e5373aaa942b631b5184f8bda8fbe1410c8875bf8499a2b61dc18b7bdfa29a3c18edf98c28dc189a493a3f5794a0020a0211b7d5d3814b33994603dcc59 WHIRLPOOL 6b0b41d3edacafba6ae5df5b0f4ccf1fb5877c938acdd2d66c443bf10c43fcc9213f08cfff212a1a259d9f767138cd04fc1c481db1594d426784b0ce5702ee5f
+DIST linkchecker-9.3.1.tar.gz 779286 SHA256 612728431204e1cab808d633b6f3751be67f9f5ac0cf582be248352bc1a8408c SHA512 355c9d262502e123732807b5aaabc17060d267de44a6dc1fee9dd6655c56320ded0c1ff638d985c2dbec366d15803cfb78fae4c1a9943de11c5b4292f5a99305 WHIRLPOOL 90310eaf43d7e5c2b6af530333a46c6d834cc845a4856ad51c26000be2c42c865dfbf45fd2a2629dff253c4584724a43bfb6a85b23a8aa1e6c594136556957e5
diff --git a/net-analyzer/linkchecker/files/linkchecker-9.3.1-build-fix.patch b/net-analyzer/linkchecker/files/linkchecker-9.3.1-build-fix.patch
new file mode 100644
index 000000000000..bcfd2cc800e4
--- /dev/null
+++ b/net-analyzer/linkchecker/files/linkchecker-9.3.1-build-fix.patch
@@ -0,0 +1,14 @@
+diff --git a/setup.py b/setup.py
+index b42ed8c..ec206e6 100755
+--- a/setup.py
++++ b/setup.py
+@@ -654,8 +654,7 @@ myemail = "bastian.kleineidam@web.de"
+
+ data_files = [
+ ('share/linkchecker',
+- ['config/linkcheckerrc',
+- 'doc/html/lccollection.qhc', 'doc/html/lcdoc.qch']),
++ ['config/linkcheckerrc']),
+ ('share/linkchecker/examples',
+ ['cgi-bin/lconline/leer.html.en',
+ 'cgi-bin/lconline/leer.html.de',
diff --git a/net-analyzer/linkchecker/linkchecker-9.3-r2.ebuild b/net-analyzer/linkchecker/linkchecker-9.3-r2.ebuild
index e0b3d0f0fb54..dd9526e518aa 100644
--- a/net-analyzer/linkchecker/linkchecker-9.3-r2.ebuild
+++ b/net-analyzer/linkchecker/linkchecker-9.3-r2.ebuild
@@ -22,7 +22,7 @@ IUSE="gnome sqlite X"
RDEPEND="
virtual/python-dnspython[${PYTHON_USEDEP}]
- >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ <dev-python/requests-2.15[${PYTHON_USEDEP}]
gnome? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
X? (
dev-python/PyQt4[X,help,${PYTHON_USEDEP}]
diff --git a/net-analyzer/linkchecker/linkchecker-9.3.1.ebuild b/net-analyzer/linkchecker/linkchecker-9.3.1.ebuild
new file mode 100644
index 000000000000..512db84e331a
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-9.3.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite?"
+
+inherit bash-completion-r1 distutils-r1 eutils multilib
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="https://github.com/linkcheck/linkchecker"
+SRC_URI="https://github.com/linkcheck/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-solaris"
+IUSE="gnome sqlite X"
+
+RDEPEND="
+ virtual/python-dnspython[${PYTHON_USEDEP}]
+ <dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ gnome? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
+ X? (
+ dev-python/PyQt4[X,help,${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
+ )"
+DEPEND="
+ X? (
+ dev-qt/qthelp:4
+ dev-python/markdown2[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="test"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-9.2-unbundle.patch"
+ "${FILESDIR}/${PN}-9.3-bash-completion.patch"
+ "${FILESDIR}/${PN}-9.3-desktop.patch"
+ "${FILESDIR}/${PN}-9.3.1-build-fix.patch"
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ DOCS=(
+ doc/upgrading.txt
+ doc/python3.txt
+ doc/changelog.txt
+ doc/development.txt
+ )
+ distutils-r1_python_install_all
+ if ! use X; then
+ delete_gui() {
+ rm -rf \
+ "${ED}"/usr/bin/linkchecker-gui* \
+ "${ED}"/$(python_get_sitedir)/linkcheck/gui* || die
+ }
+ python_foreach_impl delete_gui
+ rm -f "${ED}"/usr/share/applications/linkchecker*.desktop || die
+ fi
+
+ rm -f "${ED}"/usr/share/applications/linkchecker.desktop || die
+
+ newicon doc/html/logo64x64.png ${PN}.png
+
+ docinto html
+ dodoc doc/html/*
+ newbashcomp config/linkchecker-completion ${PN}
+ optfeature "bash-completion support" dev-python/argcomplete[${PYTHON_USEDEP}]
+ optfeature "Virus scanning" app-antivirus/clamav
+ optfeature "Geo IP support" dev-python/geoip-python[${PYTHON_USEDEP}]
+}