summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-14 15:27:56 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-14 16:04:12 -0500
commitc60a7da113d382a595cfb14ed4b3ae299ddecef0 (patch)
treebe30400586a836ae919c876c1943ac5701ab5678 /net-analyzer/nagios
parentsys-apps/firejail-lts: Remove vulnerable version (diff)
downloadgentoo-c60a7da113d382a595cfb14ed4b3ae299ddecef0.tar.gz
gentoo-c60a7da113d382a595cfb14ed4b3ae299ddecef0.tar.bz2
gentoo-c60a7da113d382a595cfb14ed4b3ae299ddecef0.zip
net-analyzer/nagios: remove old versions.
Gentoo-Bug: 602216 Package-Manager: portage-2.3.0
Diffstat (limited to 'net-analyzer/nagios')
-rw-r--r--net-analyzer/nagios/nagios-3.5.1.ebuild54
-rw-r--r--net-analyzer/nagios/nagios-4.0.8-r1.ebuild23
-rw-r--r--net-analyzer/nagios/nagios-4.2.3.ebuild21
3 files changed, 0 insertions, 98 deletions
diff --git a/net-analyzer/nagios/nagios-3.5.1.ebuild b/net-analyzer/nagios/nagios-3.5.1.ebuild
deleted file mode 100644
index 1d3d6486232..00000000000
--- a/net-analyzer/nagios/nagios-3.5.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI=5
-
-inherit multilib
-
-DESCRIPTION="The Nagios metapackage - merge this to pull install all of the nagios packages"
-HOMEPAGE="http://www.nagios.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ~arm64 hppa ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND="~net-analyzer/nagios-core-${PV}
- >=net-analyzer/nagios-plugins-1.4.13-r1
- !net-analyzer/nagios-imagepack"
-
-pkg_setup() {
- # Avoid upgrading from Nagios <3 as the directory structure has changed
- if has_version '<net-analyzer/nagios-3.0' ; then
- if [[ "${FORCE_UPGRADE}" ]] ; then
- echo
- ewarn "you are upgrading from an incompatible version and have"
- ewarn "FORCE_UPGRADE set, will build this package while Nagios is running."
- echo
- else
- echo
- eerror "You are upgrading from an incompatible version."
- eerror "Please be advised that installation paths have changed to a more FHS"
- eerror "compliant structure and you won't be able to easily upgrade to"
- eerror "Nagios 3 therefore. You will have to change your configuration"
- eerror "to reflect this change, for example Nagios plugins are now installed"
- eerror "into /usr/$(get_libdir)/nagios/plugins/ instead of /usr/nagios/libexec."
- echo
- eerror "If you want to upgrade now, emerge nagios with:"
- eerror " FORCE_UPGRADE=1 emerge nagios"
- die "Upgrading from an incompatible version!"
- echo
- fi
- fi
-}
-
-pkg_postrm() {
- elog "Note: this is a META ebuild for ${P}."
- elog "to remove it completely or before re-emerging"
- elog "either use 'depclean', or remove/re-emerge these packages:"
- elog
- for dep in ${RDEPEND}; do
- elog " ${dep}"
- done
- echo
-}
diff --git a/net-analyzer/nagios/nagios-4.0.8-r1.ebuild b/net-analyzer/nagios/nagios-4.0.8-r1.ebuild
deleted file mode 100644
index 6e9f8120f5d..00000000000
--- a/net-analyzer/nagios/nagios-4.0.8-r1.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-DESCRIPTION="The Nagios metapackage"
-HOMEPAGE="http://www.nagios.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND="~net-analyzer/nagios-core-${PV}
- || ( net-analyzer/nagios-plugins net-analyzer/monitoring-plugins )
- !net-analyzer/nagios-imagepack"
-
-pkg_postrm() {
- elog "Note: this is a meta package for ${PN}."
- elog "To remove it completely, or before re-emerging,"
- elog "use emerge --depclean."
-}
diff --git a/net-analyzer/nagios/nagios-4.2.3.ebuild b/net-analyzer/nagios/nagios-4.2.3.ebuild
deleted file mode 100644
index d7f34c1669a..00000000000
--- a/net-analyzer/nagios/nagios-4.2.3.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-DESCRIPTION="The Nagios metapackage"
-HOMEPAGE="http://www.nagios.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc x86"
-IUSE=""
-
-RDEPEND="~net-analyzer/nagios-core-${PV}
- || ( net-analyzer/nagios-plugins net-analyzer/monitoring-plugins )"
-
-pkg_postrm() {
- elog "Note: ${CATEGORY}/${PN} is a metapackage for ${PN}."
- elog "To remove it completely, use emerge --depclean."
-}