summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-08-28 14:40:53 +0200
committerMarek Szuba <marecki@gentoo.org>2020-08-28 14:40:53 +0200
commit9132b305a6b5a5663378b361c696757bfb84d39a (patch)
treeb88837496d7182bceeedbfe08f93096139db66ca /net-analyzer/nessus-agent-bin
parentnet-analyzer/nessus-bin: handle version updates properly (diff)
downloadgentoo-9132b305a6b5a5663378b361c696757bfb84d39a.tar.gz
gentoo-9132b305a6b5a5663378b361c696757bfb84d39a.tar.bz2
gentoo-9132b305a6b5a5663378b361c696757bfb84d39a.zip
net-analyzer/nessus-agent-bin: handle version updates properly
Nessus must be made aware of a new version of its core components having been installed. Do it the same way as upstream distro packages, i.e. use the undocumented nessuscli command 'install'. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-analyzer/nessus-agent-bin')
-rw-r--r--net-analyzer/nessus-agent-bin/nessus-agent-bin-8.0.0-r1.ebuild (renamed from net-analyzer/nessus-agent-bin/nessus-agent-bin-8.0.0.ebuild)8
1 files changed, 8 insertions, 0 deletions
diff --git a/net-analyzer/nessus-agent-bin/nessus-agent-bin-8.0.0.ebuild b/net-analyzer/nessus-agent-bin/nessus-agent-bin-8.0.0-r1.ebuild
index d53ad12d43a1..bcc8308edd06 100644
--- a/net-analyzer/nessus-agent-bin/nessus-agent-bin-8.0.0.ebuild
+++ b/net-analyzer/nessus-agent-bin/nessus-agent-bin-8.0.0-r1.ebuild
@@ -50,6 +50,12 @@ src_install() {
}
pkg_postinst() {
+ # Actually update Nessus core components. According to upstream packages,
+ # harmless to invoke on fresh installations too - and it may make life easier
+ # for people who had restored Nessus state from backups, had it lying around
+ # from older installations and so on.
+ "${EROOT}"/opt/nessus_agent/sbin/nessuscli install "${EROOT}"/opt/nessus_agent/var/nessus/plugins-core.tar.gz
+
if [[ -z "${REPLACING_VERSIONS}" ]]; then
elog "In order to link the agent to Tenable.io or an instance of Nessus Manager,"
elog "obtain an appropriate linking key and run"
@@ -57,5 +63,7 @@ pkg_postinst() {
elog " /opt/nessus_agent/sbin/nessuscli agent link --key=<key> --host=<host> --port=<port> [optional parameters]"
elog ""
elog "This can be done before the agent is started."
+ else
+ elog "Please restart the nessusagent service to complete the update process"
fi
}