summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-05-23 21:37:20 +0200
committerFabian Groffen <grobian@gentoo.org>2016-05-23 21:37:31 +0200
commit095a727d0ba5c3a703a501dc71d7ddaf80e83041 (patch)
tree3f10c4a639127dd32ceb87603dcd1d96dfc4bc44 /net-analyzer/openbsd-netcat
parentsys-fs/ntfs3g: move symlinks back to /usr #578336 (diff)
downloadgentoo-095a727d0ba5c3a703a501dc71d7ddaf80e83041.tar.gz
gentoo-095a727d0ba5c3a703a501dc71d7ddaf80e83041.tar.bz2
gentoo-095a727d0ba5c3a703a501dc71d7ddaf80e83041.zip
net-analyzer/openbsd-netcat: revbump to install as nc (blocking netcat), bug #582884, respect CC, CFLAGS and LDFLAGS
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-analyzer/openbsd-netcat')
-rw-r--r--net-analyzer/openbsd-netcat/openbsd-netcat-1.105-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/openbsd-netcat/openbsd-netcat-1.105-r1.ebuild b/net-analyzer/openbsd-netcat/openbsd-netcat-1.105-r1.ebuild
new file mode 100644
index 000000000000..c4d9efa17197
--- /dev/null
+++ b/net-analyzer/openbsd-netcat/openbsd-netcat-1.105-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="The OpenBSD network swiss army knife"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/nc/"
+SRC_URI="http://http.debian.net/debian/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}.orig.tar.gz
+ http://http.debian.net/debian/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}-7.debian.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x64-macos"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND="dev-libs/libbsd
+ !net-analyzer/netcat
+ !net-analyzer/netcat6
+"
+
+S=${WORKDIR}/netcat-openbsd-${PV}
+
+PATCHES=( "${WORKDIR}/debian/patches" )
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin nc
+ doman nc.1
+ cd "${WORKDIR}/debian"
+ newdoc netcat-openbsd.README.Debian README
+ dodoc -r examples
+}
+
+pkg_postinst() {
+ if [[ ${KERNEL} = "linux" ]]; then
+ ewarn "FO_REUSEPORT is introduced in linux 3.9. If your running kernel is older"
+ ewarn "and kernel header is newer, nc will not listen correctly. Matching the header"
+ ewarn "to the running kernel will do. See bug #490246 for details."
+ fi
+}