summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-18 19:18:14 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-18 20:14:46 +0100
commit0f05e9d541d5958c3abc9b7ff4e80a025f315c6a (patch)
tree3b736ff8937fcfc3fdf538d6e8552a5aede76b73 /net-analyzer/openvas-libraries
parentwww-servers/tornado: Backport KEYWORDS (diff)
downloadgentoo-0f05e9d541d5958c3abc9b7ff4e80a025f315c6a.tar.gz
gentoo-0f05e9d541d5958c3abc9b7ff4e80a025f315c6a.tar.bz2
gentoo-0f05e9d541d5958c3abc9b7ff4e80a025f315c6a.zip
net-analyzer/openvas-libraries: Update patch to work with ld.bfd
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-analyzer/openvas-libraries')
-rw-r--r--net-analyzer/openvas-libraries/files/openvas-libraries-8.0.5-underlinking.patch24
1 files changed, 15 insertions, 9 deletions
diff --git a/net-analyzer/openvas-libraries/files/openvas-libraries-8.0.5-underlinking.patch b/net-analyzer/openvas-libraries/files/openvas-libraries-8.0.5-underlinking.patch
index 3bd1208b55a7..817815edb317 100644
--- a/net-analyzer/openvas-libraries/files/openvas-libraries-8.0.5-underlinking.patch
+++ b/net-analyzer/openvas-libraries/files/openvas-libraries-8.0.5-underlinking.patch
@@ -1,9 +1,9 @@
- base/CMakeLists.txt | 4 ++--
- misc/CMakeLists.txt | 2 +-
- 2 files changed, 3 insertions(+), 3 deletions(-)
+ base/CMakeLists.txt | 10 +++++-----
+ misc/CMakeLists.txt | 2 +-
+ 2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/base/CMakeLists.txt b/base/CMakeLists.txt
-index 07febee..512e813 100644
+index 07febee..40305b7 100644
--- a/base/CMakeLists.txt
+++ b/base/CMakeLists.txt
@@ -73,7 +73,7 @@ if (BUILD_SHARED)
@@ -15,15 +15,21 @@ index 07febee..512e813 100644
endif (MINGW)
endif (BUILD_SHARED)
-@@ -89,7 +89,7 @@ add_custom_indent_targets (${FILES})
+@@ -87,10 +87,10 @@ add_custom_indent_targets (${FILES})
+
+ # Link the test-hosts executable
# TODO: This is currently only built for BUILD_SHARED
- if (BUILD_SHARED)
- add_executable (test-hosts test-hosts.c)
+-if (BUILD_SHARED)
+- add_executable (test-hosts test-hosts.c)
- target_link_libraries (test-hosts openvas_base_shared ${GNUTLS_LDFLAGS} openvas_misc_shared ${GLIB_LDFLAGS})
-+ target_link_libraries (test-hosts openvas_base_shared ${GNUTLS_LDFLAGS} openvas_misc_shared openvas_omp_shared ${GLIB_LDFLAGS})
- endif (BUILD_SHARED)
+-endif (BUILD_SHARED)
++#if (BUILD_SHARED)
++# add_executable (test-hosts test-hosts.c)
++# target_link_libraries (test-hosts openvas_base_shared ${GNUTLS_LDFLAGS} openvas_misc_shared openvas_omp_shared ${GLIB_LDFLAGS})
++#endif (BUILD_SHARED)
## Install
+ if (BUILD_STATIC)
diff --git a/misc/CMakeLists.txt b/misc/CMakeLists.txt
index 7aaca2c..e7a0870 100644
--- a/misc/CMakeLists.txt