summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-05-28 14:00:21 +0200
committerJeroen Roovers <jer@gentoo.org>2019-05-28 14:08:23 +0200
commit9a0a342d2f4d89e0ae858b5c2618d9a5f77bf579 (patch)
tree8b914e68c4e635b906332619170ef806f703004f /net-analyzer/pypacker
parentx11-misc/zim: Version 0.71.1 (diff)
downloadgentoo-9a0a342d2f4d89e0ae858b5c2618d9a5f77bf579.tar.gz
gentoo-9a0a342d2f4d89e0ae858b5c2618d9a5f77bf579.tar.bz2
gentoo-9a0a342d2f4d89e0ae858b5c2618d9a5f77bf579.zip
net-analyzer/pypacker: Version 4.7
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/pypacker')
-rw-r--r--net-analyzer/pypacker/Manifest1
-rw-r--r--net-analyzer/pypacker/pypacker-4.7.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/pypacker/Manifest b/net-analyzer/pypacker/Manifest
index 8ef31bcff028..f0aff0c8922c 100644
--- a/net-analyzer/pypacker/Manifest
+++ b/net-analyzer/pypacker/Manifest
@@ -1,2 +1,3 @@
DIST pypacker-2.9.tar.gz 276080 BLAKE2B 3bab4b4c7879fea10accbd3fb2bcb4a8e27096a29240f6b8e4e06c3486ee0cb2b8fa1e83674dee759fafc85c2e182cb75e836c00dfe28c83c0bb2cecaed758cd SHA512 b7ca61948a55a37661fa402ebc5a9c2be456e8df14d1ee091a50ccd1362c7a7fa9224e1ae2b8ee8057f302ee9e0c61c06d07b627dde92947f8d22158ef3623b8
DIST pypacker-4.6.tar.gz 592362 BLAKE2B 41fc63f1fc40ab1cfc007db9dfc6d18cedb51cc8525dc2b467bc03babe03c49f9f0771b8146aacf80f74c511619da85e1f7d56667bcda350710e4c0bafb89351 SHA512 c55205b35f653903149517aad0e2d055745edd6c1a28b1b49aeaa435ca327693b20ed6f851011fa80df1fcc5281ac8b92fbffa3b1381cb3d4507ef7d45d49545
+DIST pypacker-4.7.tar.gz 595975 BLAKE2B 95f29bf88347df5c4673a225049337c053cc4833a13767a3fce700a911fb7b744a61ea745f3d3ac4a14cc93288504e190c9cda228000b8a41b924b23805efcf3 SHA512 9c874af28887e942f62a7f540961f7e31af3b35e52f960ec99ed53e6a5ea29d36f20a6dbcf652125ac6b72849502a30e5d11ee1f795c90c7efd5702a0d34b2b3
diff --git a/net-analyzer/pypacker/pypacker-4.7.ebuild b/net-analyzer/pypacker/pypacker-4.7.ebuild
new file mode 100644
index 000000000000..7c4a61cdce42
--- /dev/null
+++ b/net-analyzer/pypacker/pypacker-4.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6} )
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Fast and simple packet creation and parsing library for Python"
+HOMEPAGE="https://gitlab.com/mike01/pypacker"
+SRC_URI="${HOMEPAGE}/-/archive/v${PV}/pypacker-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS CHANGES HACKING README.md )
+
+python_test() {
+ "${PYTHON}" tests/test_pypacker.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}