summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-12-16 21:29:06 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-01-03 12:09:22 +0200
commit4fba5c78ab07761ebda3ca2e29f9c89df9d62c9a (patch)
tree6755f743fec3981d9ee2c9477d56e571223a01f7 /net-analyzer/python-gvm/python-gvm-1.1.0.ebuild
parentapp-emacs/slime: amd64 stable wrt bug #704554 (diff)
downloadgentoo-4fba5c78ab07761ebda3ca2e29f9c89df9d62c9a.tar.gz
gentoo-4fba5c78ab07761ebda3ca2e29f9c89df9d62c9a.tar.bz2
gentoo-4fba5c78ab07761ebda3ca2e29f9c89df9d62c9a.zip
net-analyzer/python-gvm: new package
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Closes: https://github.com/gentoo/gentoo/pull/14017 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/python-gvm/python-gvm-1.1.0.ebuild')
-rw-r--r--net-analyzer/python-gvm/python-gvm-1.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/python-gvm/python-gvm-1.1.0.ebuild b/net-analyzer/python-gvm/python-gvm-1.1.0.ebuild
new file mode 100644
index 000000000000..337868c6e65a
--- /dev/null
+++ b/net-analyzer/python-gvm/python-gvm-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Greenbone Vulnerability Management Python Library"
+HOMEPAGE="https://www.greenbone.net/en/"
+SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ distutils-r1_python_prepare_all
+ # Exlude tests & docs to fix build issue
+ sed \
+ -e "s/packages=find_packages(exclude=.*/packages=find_packages(exclude=['tests*', 'docs']),/g" \
+ -i "$S"/setup.py || die
+}