summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/sguil-client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/sguil-client')
-rw-r--r--net-analyzer/sguil-client/Manifest2
-rw-r--r--net-analyzer/sguil-client/metadata.xml8
-rw-r--r--net-analyzer/sguil-client/sguil-client-0.8.0.ebuild50
-rw-r--r--net-analyzer/sguil-client/sguil-client-0.9.0.ebuild48
4 files changed, 108 insertions, 0 deletions
diff --git a/net-analyzer/sguil-client/Manifest b/net-analyzer/sguil-client/Manifest
new file mode 100644
index 000000000000..1a10dae2dcfc
--- /dev/null
+++ b/net-analyzer/sguil-client/Manifest
@@ -0,0 +1,2 @@
+DIST sguil-0.9.0.tar.gz 464204 SHA256 412be894d67a6487312dd16a98a580dda8c38cff2e24f7a6c25405857769782b SHA512 3f300901d0f0260fbc950b4c7604e3dc3eeb2d088ff45171db84e2d58e281242bf3582eac51162968f1f3766961aec4d0a7af54e85773102ee643a52e879cfa6 WHIRLPOOL eaaef918819ed781505abc727c65e08a9e6d6d0e53f842b5aa6ec4cd1278dc902375a45794b3989488c3507bc34e288593cd892c8a94293d8a7723bbdb6cef4e
+DIST sguil-client-0.8.0.tar.gz 216433 SHA256 bbce49630fd6264591a1e890cba3bad11cf18e9327c9f9cc02cb6dc8a19746bd SHA512 44e14273cb7506b89d3138a1c50160de99576e77d6d18e3cdab9f257a1d00d5a100c8d9790f6e93aea8312fab51d52260aedfaa00facf54107249686d93e09b3 WHIRLPOOL c7213ebcebd8eaf6418f9a0a9c6e7b5df4d507d434c0b10bc2f9a1d6bf0337d590b600af0335792b92d735fa5e71cd5547528f17d750064f98267cb331efccb4
diff --git a/net-analyzer/sguil-client/metadata.xml b/net-analyzer/sguil-client/metadata.xml
new file mode 100644
index 000000000000..f5369ffcdbd8
--- /dev/null
+++ b/net-analyzer/sguil-client/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="github">bammv/sguil</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/sguil-client/sguil-client-0.8.0.ebuild b/net-analyzer/sguil-client/sguil-client-0.8.0.ebuild
new file mode 100644
index 000000000000..4b8b0b9fe158
--- /dev/null
+++ b/net-analyzer/sguil-client/sguil-client-0.8.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+MY_PV="${PV/_p/p}"
+DESCRIPTION="GUI Console for sguil Network Security Monitoring"
+HOMEPAGE="http://sguil.sf.net"
+SRC_URI="mirror://sourceforge/sguil/sguil-client-${MY_PV}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="
+ >=dev-lang/tcl-8.3:0=[-threads]
+ >=dev-lang/tk-8.3:0=
+ >=dev-tcltk/itcl-3.2
+ >=dev-tcltk/tclx-8.3
+ dev-tcltk/itk
+ dev-tcltk/iwidgets
+ dev-tcltk/tcllib
+ net-analyzer/wireshark
+ ssl? ( >=dev-tcltk/tls-1.4.1 )
+"
+
+S=${WORKDIR}/sguil-${MY_PV}
+
+src_prepare() {
+ sed -i \
+ -e "/^set SGUILLIB /s:./lib:/usr/$(get_libdir)/sguil:" \
+ -e '/^set ETHEREAL_PATH /s:/usr/sbin/ethereal:/usr/bin/wireshark:' \
+ -e '/^set SERVERHOST /s:demo.sguil.net:localhost:' \
+ -e '/^set MAILSERVER /s:mail.example.com:localhost:' \
+ -e '/^set GPG_PATH /s:/usr/local/bin/gpg:/usr/bin/gpg:' \
+ client/sguil.conf || die
+}
+
+src_install() {
+ dobin client/sguil.tk
+ insinto /etc/sguil
+ doins client/sguil.conf
+ insinto "/usr/$(get_libdir)/sguil"
+ doins -r "${S}"/client/lib/*
+ dodoc doc/*
+}
diff --git a/net-analyzer/sguil-client/sguil-client-0.9.0.ebuild b/net-analyzer/sguil-client/sguil-client-0.9.0.ebuild
new file mode 100644
index 000000000000..66d3c531be30
--- /dev/null
+++ b/net-analyzer/sguil-client/sguil-client-0.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib
+
+MY_PV="${PV/_p/p}"
+DESCRIPTION="GUI Console for sguil Network Security Monitoring"
+HOMEPAGE="http://sguil.sf.net"
+SRC_URI="https://github.com/bammv/${PN/-client}/archive/v${PV}.tar.gz -> ${P/-client}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="
+ >=dev-lang/tcl-8.3:0=[-threads]
+ >=dev-lang/tk-8.3:0=
+ >=dev-tcltk/itcl-3.2
+ >=dev-tcltk/tclx-8.3
+ dev-tcltk/itk
+ dev-tcltk/iwidgets
+ dev-tcltk/tcllib
+ net-analyzer/wireshark
+ ssl? ( >=dev-tcltk/tls-1.4.1 )
+"
+
+S=${WORKDIR}/sguil-${MY_PV}
+
+src_prepare() {
+ sed -i \
+ -e "/^set SGUILLIB /s:./lib:/usr/$(get_libdir)/sguil:" \
+ -e '/^set SERVERHOST /s:demo.sguil.net:localhost:' \
+ -e '/^set MAILSERVER /s:mail.example.com:localhost:' \
+ -e '/^set GPG_PATH /s:/usr/local/bin/gpg:/usr/bin/gpg:' \
+ client/sguil.conf || die
+}
+
+src_install() {
+ dobin client/sguil.tk
+ insinto /etc/sguil
+ doins client/sguil.conf
+ insinto "/usr/$(get_libdir)/sguil"
+ doins -r "${S}"/client/lib/*
+ dodoc doc/*
+}