summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-10-24 10:00:01 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-10-24 10:02:15 -0500
commitf27c272aa3eec5c89fc1966d9ce96db7f32f5e41 (patch)
treed97c572e746420ec914f2fa3632495ff4b73b3c5 /net-analyzer/sshping/sshping-0.1.4.ebuild
parentdev-perl/Exporter-Lite: EAPI=8 bump (diff)
downloadgentoo-f27c272aa3eec5c89fc1966d9ce96db7f32f5e41.tar.gz
gentoo-f27c272aa3eec5c89fc1966d9ce96db7f32f5e41.tar.bz2
gentoo-f27c272aa3eec5c89fc1966d9ce96db7f32f5e41.zip
net-analyzer/sshping: initial import
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-analyzer/sshping/sshping-0.1.4.ebuild')
-rw-r--r--net-analyzer/sshping/sshping-0.1.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/sshping/sshping-0.1.4.ebuild b/net-analyzer/sshping/sshping-0.1.4.ebuild
new file mode 100644
index 000000000000..86789a0acf0d
--- /dev/null
+++ b/net-analyzer/sshping/sshping-0.1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ssh-based ping: measure character echo latency and bandwidth"
+HOMEPAGE="https://github.com/spook/sshping"
+SRC_URI="https://github.com/spook/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-lang/perl"
+DEPEND="net-libs/libssh:="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-man-dir.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ )
+
+ cmake_src_configure
+}