summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-13 16:18:46 +0000
committerSam James <sam@gentoo.org>2022-02-13 16:19:25 +0000
commitf59a2f395f9edd7db3c03ac4628300e417f827b3 (patch)
treecaf2a71b310dd8bd218488b7ae9148b98652c354 /net-analyzer/tcpreplay
parentapp-admin/graylog: Remove obsolete blocker (diff)
downloadgentoo-f59a2f395f9edd7db3c03ac4628300e417f827b3.tar.gz
gentoo-f59a2f395f9edd7db3c03ac4628300e417f827b3.tar.bz2
gentoo-f59a2f395f9edd7db3c03ac4628300e417f827b3.zip
net-analyzer/tcpreplay: add 4.4.1
Bug: https://bugs.gentoo.org/833139 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/tcpreplay')
-rw-r--r--net-analyzer/tcpreplay/Manifest1
-rw-r--r--net-analyzer/tcpreplay/files/tcpreplay-4.4.1-fix-bashism-configure.patch34
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.4.1.ebuild85
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-9999.ebuild (renamed from net-analyzer/tcpreplay/tcpreplay-999999.ebuild)2
4 files changed, 121 insertions, 1 deletions
diff --git a/net-analyzer/tcpreplay/Manifest b/net-analyzer/tcpreplay/Manifest
index ddd047da0039..ad3c5de2681d 100644
--- a/net-analyzer/tcpreplay/Manifest
+++ b/net-analyzer/tcpreplay/Manifest
@@ -1 +1,2 @@
DIST tcpreplay-4.3.4.tar.xz 739280 BLAKE2B 8b680363ee182fc7581f99cc4587d50e36285446d07a5be370e2439b31582ad88c786c11d662e28dadc5b69aee376889b1c0f6a86d61c106426ab6ab2c085012 SHA512 6d19cf492114c68a9fafcf7790c08f31607d2c0112e02fa41eed8747255bbbef85f281f74348e1d51f1d476b88f07d64715224618ec15268688baefaf7cc7124
+DIST tcpreplay-4.4.1.tar.xz 751036 BLAKE2B cf6a4e23f68fd0d6f23392c3ded14ea6486d275eeb8e278ce02d6b34e8b426e69841858cac49cc5ea952e0398f2960049789d16180b0896e38d665511237b352 SHA512 25a4a94b7c0c416b8ef57aba5640803dcd6e271fe8789f3f6e281529e336e326b35738d7673fd44ac4ded0faf577dc4c6255b926bd67b8ba5104a8bad81a98f1
diff --git a/net-analyzer/tcpreplay/files/tcpreplay-4.4.1-fix-bashism-configure.patch b/net-analyzer/tcpreplay/files/tcpreplay-4.4.1-fix-bashism-configure.patch
new file mode 100644
index 000000000000..f1d424274333
--- /dev/null
+++ b/net-analyzer/tcpreplay/files/tcpreplay-4.4.1-fix-bashism-configure.patch
@@ -0,0 +1,34 @@
+https://github.com/appneta/tcpreplay/pull/714
+
+From bd93776c50ec1d0574c72f253095afe22eb6bf73 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 13 Feb 2022 16:09:23 +0000
+Subject: [PATCH] build: fix bashism in configure
+
+configure scripts are run with /bin/sh which is supposed
+to be a POSIX-compliant shell, so if /bin/sh is provided
+by e.g. dash (like on Debian) rather than bash, we hit
+errors.
+
+This has no effect on functionality for bash &
+retains compatibility.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 11a1e4ea..4c577c42 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1808,7 +1808,7 @@ fi
+ dnl No 'make test' when cross compile
+
+ AC_MSG_CHECKING(for 'make test' profile)
+-if test "$host" == "$build" ; then
++if test "$host" = "$build" ; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_WARN(Unable to do tests when cross-compiling)
+
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.4.1.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.4.1.ebuild
new file mode 100644
index 000000000000..35febc8f8703
--- /dev/null
+++ b/net-analyzer/tcpreplay/tcpreplay-4.4.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Utilities for editing and replaying previously captured network traffic"
+HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/appneta/tcpreplay"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~sparc ~x86"
+fi
+
+S="${WORKDIR}"/${P/_/-}
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+IUSE="debug pcapnav +tcpdump"
+
+# libpcapnav for pcapnav-config
+BDEPEND="
+ net-libs/libpcapnav
+ >=sys-devel/autogen-5.18.4[libopts]
+"
+DEPEND="
+ dev-libs/libdnet
+ >=net-libs/libpcap-0.9
+ pcapnav? ( net-libs/libpcapnav )
+ tcpdump? ( net-analyzer/tcpdump )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
+ "${FILESDIR}"/${PN}-4.4.1-fix-bashism-configure.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
+ src/common/sendpacket.c || die
+ sed -i \
+ -e 's|@\([A-Z_]*\)@|$(\1)|g' \
+ -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
+ -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
+ src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # By default it uses static linking. Avoid that, bug #252940
+ econf \
+ $(use_enable debug) \
+ $(use_with pcapnav pcapnav-config "${BROOT}"/usr/bin/pcapnav-config) \
+ $(use_with tcpdump tcpdump "${ESYSROOT}"/usr/sbin/tcpdump) \
+ --enable-dynamic-link \
+ --enable-local-libopts \
+ --enable-shared \
+ --with-libdnet \
+ --with-testnic2=lo \
+ --with-testnic=lo
+}
+
+src_test() {
+ if [[ ! ${EUID} -eq 0 ]] ; then
+ ewarn "Some tests were disabled due to FEATURES=userpriv"
+ ewarn "To run all tests issue the following command as root:"
+ ewarn " # make -C ${S}/test"
+ emake -j1 -C test tcpprep
+ else
+ emake -j1 test || {
+ ewarn "Note that some tests require eth0 iface to be up."
+ die "self test failed - see ${S}/test/test.log"
+ }
+ fi
+}
diff --git a/net-analyzer/tcpreplay/tcpreplay-999999.ebuild b/net-analyzer/tcpreplay/tcpreplay-9999.ebuild
index 52407c59ac72..ab3477f795b6 100644
--- a/net-analyzer/tcpreplay/tcpreplay-999999.ebuild
+++ b/net-analyzer/tcpreplay/tcpreplay-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7