summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 01:45:09 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:55:19 +0100
commit1e9ee33e246278346f762d5d1513bbce948d728d (patch)
tree805cac4153425e4af2c7bd375ed149b7bc90be56 /net-analyzer/tptest
parentnet-analyzer/tcptrack: port to EAPI 7 (diff)
downloadgentoo-1e9ee33e246278346f762d5d1513bbce948d728d.tar.gz
gentoo-1e9ee33e246278346f762d5d1513bbce948d728d.tar.bz2
gentoo-1e9ee33e246278346f762d5d1513bbce948d728d.zip
net-analyzer/tptest: port to EAPI 7, eutils--, misc QA fixes
* Standard ebuild "block structure" * Quoting * Drop unused eutils * Missing || dies Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/tptest')
-rw-r--r--net-analyzer/tptest/tptest-3.1.7-r2.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/net-analyzer/tptest/tptest-3.1.7-r2.ebuild b/net-analyzer/tptest/tptest-3.1.7-r2.ebuild
index 709ad3a89a3e..6187c9661381 100644
--- a/net-analyzer/tptest/tptest-3.1.7-r2.ebuild
+++ b/net-analyzer/tptest/tptest-3.1.7-r2.ebuild
@@ -1,35 +1,42 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit toolchain-funcs eutils
+EAPI=7
+
+inherit toolchain-funcs
MY_PV="${PV/./_}"
DESCRIPTION="Internet bandwidth tester"
HOMEPAGE="http://tptest.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="amd64 ppc sparc x86"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.7-getstatsfromlinevuln.patch
+)
+
src_prepare() {
+ default
+
sed -i apps/unix/{client,server}/Makefile \
-e "s:^CFLAGS[[:space:]]*=:CFLAGS+=:" \
|| die
- epatch "${FILESDIR}/${PN}-3.1.7-getstatsfromlinevuln.patch"
- cp -f os-dep/unix/* .
- cp -f engine/* .
+
+ cp -f os-dep/unix/* . || die
+ cp -f engine/* . || die
}
src_compile() {
emake -C apps/unix/client \
- CC=$(tc-getCC) \
+ CC="$(tc-getCC)" \
LDFLAGS="${LDFLAGS}"
emake -C apps/unix/server \
- CC=$(tc-getCC) \
+ CC="$(tc-getCC)" \
LDFLAGS="${LDFLAGS}"
}