summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-06-03 14:11:25 +0200
committerJeroen Roovers <jer@gentoo.org>2018-06-03 14:12:12 +0200
commit1ed92cf1f83756341e962f39e9c6f85cda353ed8 (patch)
treeddba468a6c0f9d42d4c92ad3bf02f75fb7e5e93c /net-analyzer/wireshark/files
parentmedia-video/kino: Drop 1.3.4 (diff)
downloadgentoo-1ed92cf1f83756341e962f39e9c6f85cda353ed8.tar.gz
gentoo-1ed92cf1f83756341e962f39e9c6f85cda353ed8.tar.bz2
gentoo-1ed92cf1f83756341e962f39e9c6f85cda353ed8.zip
net-analyzer/wireshark: Update live ebuild.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-analyzer/wireshark/files')
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch34
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-ui-needs-wiretap.patch11
2 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch b/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch
new file mode 100644
index 000000000000..8ceb3ba54882
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch
@@ -0,0 +1,34 @@
+--- a/extcap/CMakeLists.txt
++++ b/extcap/CMakeLists.txt
+@@ -68,6 +68,8 @@
+ if(HAVE_LIBPCAP)
+ set(androiddump_LIBS
+ ui
++ wiretap
++ wsutil
+ ${GLIB2_LIBRARIES}
+ ${PCAP_LIBRARIES}
+ )
+@@ -78,6 +80,7 @@
+ set(androiddump_LIBS
+ ui
+ wiretap
++ wsutil
+ ${GLIB2_LIBRARIES}
+ ${ZLIB_LIBRARIES}
+ ${CMAKE_DL_LIBS}
+@@ -89,7 +92,6 @@
+ )
+
+ add_executable(androiddump WIN32 ${androiddump_FILES})
+- # XXX Shouldn't we add wsutil to androiddump_LIBS instead?
+ set_extcap_executable_properties(androiddump)
+ target_link_libraries(androiddump ${androiddump_LIBS})
+ install(TARGETS androiddump RUNTIME DESTINATION ${EXTCAP_DIR})
+@@ -212,4 +214,4 @@
+ ${androiddump_FILES}
+ ${sshdump_FILES}
+ ${ciscodump_FILES}
+-)
+\ No newline at end of file
++)
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-ui-needs-wiretap.patch b/net-analyzer/wireshark/files/wireshark-99999999-ui-needs-wiretap.patch
new file mode 100644
index 000000000000..c0bfc3acd5a6
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-99999999-ui-needs-wiretap.patch
@@ -0,0 +1,11 @@
+--- a/ui/CMakeLists.txt
++++ b/ui/CMakeLists.txt
+@@ -76,6 +76,8 @@
+
+ add_library(ui STATIC ${UI_SRC})
+
++set(ui_LIBS wiretap)
++
+ set_target_properties(ui PROPERTIES
+ LINK_FLAGS "${WS_LINK_FLAGS}"
+ FOLDER "UI"