summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-04-26 12:36:27 +0200
committerJeroen Roovers <jer@gentoo.org>2020-04-26 12:39:18 +0200
commitff2582375047ee9d7849183cd8f6bef3463ee0f2 (patch)
tree79b19322d18960cc223130772c0187482ab6cb6c /net-analyzer/wireshark
parentsci-mathematics/pari: remove DOCS array, works fine without (diff)
downloadgentoo-ff2582375047ee9d7849183cd8f6bef3463ee0f2.tar.gz
gentoo-ff2582375047ee9d7849183cd8f6bef3463ee0f2.tar.bz2
gentoo-ff2582375047ee9d7849183cd8f6bef3463ee0f2.zip
net-analyzer/wireshark: Add some test requirements
According to test/README.test: - pytest{,-xdist} are needed - the test-programs target needs to be built (manually) This should allow the suite_unittests target to pass. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/wireshark')
-rw-r--r--net-analyzer/wireshark/wireshark-3.2.3.ebuild7
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/wireshark-3.2.3.ebuild b/net-analyzer/wireshark/wireshark-3.2.3.ebuild
index a09e19cba2a7..032bafbb15ba 100644
--- a/net-analyzer/wireshark/wireshark-3.2.3.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.2.3.ebuild
@@ -17,7 +17,7 @@ IUSE="
+dumpcap +editcap http2 kerberos libxml2 lua lz4 maxminddb +mergecap
+minizip +netlink +plugins plugin-ifdemo +pcap +qt5 +randpkt +randpktdump
+reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl sdjournal
- +text2pcap tfshark +tshark +udpdump zlib +zstd
+ test +text2pcap tfshark +tshark +udpdump zlib +zstd
"
S=${WORKDIR}/${P/_/}
@@ -74,6 +74,10 @@ BDEPEND="
qt5? (
dev-qt/linguist-tools:5
)
+ test? (
+ dev-python/pytest
+ dev-python/pytest-xdist
+ )
"
RDEPEND="
${CDEPEND}
@@ -174,6 +178,7 @@ src_configure() {
}
src_test() {
+ cmake_build test-programs
cmake_src_test
}
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 6f9470ca6ee5..86206f1ead23 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -17,7 +17,7 @@ IUSE="
+dumpcap +editcap http2 kerberos libxml2 lua lz4 maxminddb +mergecap
+minizip +netlink +plugins plugin-ifdemo +pcap +qt5 +randpkt +randpktdump
+reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl sdjournal
- +text2pcap tfshark +tshark +udpdump zlib
+ test +text2pcap tfshark +tshark +udpdump zlib
"
S=${WORKDIR}/${P/_/}
@@ -73,6 +73,10 @@ BDEPEND="
qt5? (
dev-qt/linguist-tools:5
)
+ test? (
+ dev-python/pytest
+ dev-python/pytest-xdist
+ )
"
RDEPEND="
${CDEPEND}
@@ -168,6 +172,7 @@ src_configure() {
}
src_test() {
+ cmake_build test-programs
cmake_src_test
}