summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-08-05 15:31:25 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-08-16 11:00:56 +0300
commit140611c54bd679c154b4c6e90d03baf704fa28a3 (patch)
tree1b8da39a991278e69eca5dddc174e69ac3794d55 /net-analyzer/zmap
parentapp-accessibility/orca: bump to 3.36.5, enable py3.8 (diff)
downloadgentoo-140611c54bd679c154b4c6e90d03baf704fa28a3.tar.gz
gentoo-140611c54bd679c154b4c6e90d03baf704fa28a3.tar.bz2
gentoo-140611c54bd679c154b4c6e90d03baf704fa28a3.zip
net-analyzer/zmap: update mycmakeargs, drop mongodb dep in 9999
- Mongo support was removed in https://github.com/zmap/zmap/pull/467 Closes: https://bugs.gentoo.org/677902 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/zmap')
-rw-r--r--net-analyzer/zmap/zmap-2.1.1.ebuild7
-rw-r--r--net-analyzer/zmap/zmap-9999.ebuild9
2 files changed, 6 insertions, 10 deletions
diff --git a/net-analyzer/zmap/zmap-2.1.1.ebuild b/net-analyzer/zmap/zmap-2.1.1.ebuild
index bab11e96bbfc..dac6ede5634e 100644
--- a/net-analyzer/zmap/zmap-2.1.1.ebuild
+++ b/net-analyzer/zmap/zmap-2.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -35,10 +35,9 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DENABLE_DEVELOPMENT=OFF
- -DENABLE_HARDENING=OFF
-DWITH_WERROR=OFF
- -DWITH_mongo="$(usex mongo)"
- -DWITH_redis="$(usex redis)"
+ -DWITH_MONGO="$(usex mongo)"
+ -DWITH_REDIS="$(usex redis)"
)
cmake-utils_src_configure
}
diff --git a/net-analyzer/zmap/zmap-9999.ebuild b/net-analyzer/zmap/zmap-9999.ebuild
index eaed24c6933d..04e4602032d2 100644
--- a/net-analyzer/zmap/zmap-9999.ebuild
+++ b/net-analyzer/zmap/zmap-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,13 +13,12 @@ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
SLOT="0"
LICENSE="Apache-2.0"
KEYWORDS=""
-IUSE="mongo redis"
+IUSE="redis"
RDEPEND="
dev-libs/gmp:0
net-libs/libpcap
dev-libs/json-c:=
- mongo? ( dev-db/mongodb )
redis? ( dev-libs/hiredis )"
DEPEND="${RDEPEND}
dev-util/gengetopt
@@ -30,10 +29,8 @@ DEPEND="${RDEPEND}
src_configure() {
local mycmakeargs=(
-DENABLE_DEVELOPMENT=OFF
- -DENABLE_HARDENING=OFF
-DWITH_WERROR=OFF
- -DWITH_mongo="$(usex mongo)"
- -DWITH_redis="$(usex redis)"
+ -DWITH_REDIS="$(usex redis)"
)
cmake-utils_src_configure
}