summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-12-07 14:02:22 +0100
committerJeroen Roovers <jer@gentoo.org>2019-12-07 14:05:10 +0100
commit23ff5f3216bf61aa543bbcf49b2bc509cbdfe9aa (patch)
treeec41d44b72599569e2f61eb800bbb79e2137ef53 /net-analyzer
parentnet-analyzer/net-snmp: Update live ebuild (diff)
downloadgentoo-23ff5f3216bf61aa543bbcf49b2bc509cbdfe9aa.tar.gz
gentoo-23ff5f3216bf61aa543bbcf49b2bc509cbdfe9aa.tar.bz2
gentoo-23ff5f3216bf61aa543bbcf49b2bc509cbdfe9aa.zip
net-analyzer/net-snmp: Revise patches
- Add patch for bug net-snmp-config LDFLAGS/LIBS confusion - Use PATCHES instead of eapply calls Package-Manager: Portage-2.3.81, Repoman-2.3.20 Closes: https://bugs.gentoo.org/693970 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.8.1_pre1.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/net-analyzer/net-snmp/net-snmp-5.8.1_pre1.ebuild b/net-analyzer/net-snmp/net-snmp-5.8.1_pre1.ebuild
index 9947bc40119f..0704a753212a 100644
--- a/net-analyzer/net-snmp/net-snmp-5.8.1_pre1.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.8.1_pre1.ebuild
@@ -28,6 +28,10 @@ IUSE="
X bzip2 doc elf kmem ipv6 libressl lm-sensors mfd-rewrites minimal mysql
netlink pcap pci perl python rpm selinux smux ssl tcpd ucd-compat zlib
"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ rpm? ( bzip2 zlib )
+"
COMMON_DEPEND="
bzip2? ( app-arch/bzip2 )
@@ -65,14 +69,15 @@ RDEPEND="
)
selinux? ( sec-policy/selinux-snmp )
"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- rpm? ( bzip2 zlib )
-"
S=${WORKDIR}/${P/_pre/.pre}
-
RESTRICT=test
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.7.3-include-limits.patch
+ "${FILESDIR}"/${PN}-5.8-do-not-conflate-LDFLAGS-and-LIBS.patch
+ "${FILESDIR}"/${PN}-5.8-pcap.patch
+ "${FILESDIR}"/${PN}-5.8-tinfo.patch
+ "${FILESDIR}"/${PN}-5.8.1-pkg-config.patch
+)
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -82,17 +87,11 @@ src_prepare() {
# snmpconf generates config files with proper selinux context
use selinux && eapply "${FILESDIR}"/${PN}-5.1.2-snmpconf-selinux.patch
- eapply "${FILESDIR}"/${PN}-5.7.3-include-limits.patch
- eapply "${FILESDIR}"/${PN}-5.8-do-not-conflate-LDFLAGS-and-LIBS.patch
- eapply "${FILESDIR}"/${PN}-5.8-pcap.patch
- eapply "${FILESDIR}"/${PN}-5.8-tinfo.patch
- eapply "${FILESDIR}"/${PN}-5.8.1-pkg-config.patch
-
mv "${WORKDIR}"/patches/0002-Respect-DESTDIR-for-pythoninstall.patch{,.disabled} || die
mv "${WORKDIR}"/patches/0004-Don-t-report-CFLAGS-and-LDFLAGS-in-net-snmp-config.patch{,.disabled} || die
eapply "${WORKDIR}"/patches/*.patch
- eapply_user
+ default
eautoconf
}