summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-11-18 13:44:12 +0100
committerJeroen Roovers <jer@gentoo.org>2017-11-18 13:44:37 +0100
commit445a53409e17b1fb837b851510a708d07d90f091 (patch)
tree9d7753901d76d8ccdf152b9825026e6cc22a6f2c /net-analyzer
parentsys-auth/consolekit: stable 1.2.0 for hppa, bug #635484 (diff)
downloadgentoo-445a53409e17b1fb837b851510a708d07d90f091.tar.gz
gentoo-445a53409e17b1fb837b851510a708d07d90f091.tar.bz2
gentoo-445a53409e17b1fb837b851510a708d07d90f091.zip
net-analyzer/nmap: Establish sys-libs/zlib dependency by Daniel M. Weeks (bug #637514).
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/files/nmap-9999-zlib.patch11
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild13
2 files changed, 19 insertions, 5 deletions
diff --git a/net-analyzer/nmap/files/nmap-9999-zlib.patch b/net-analyzer/nmap/files/nmap-9999-zlib.patch
new file mode 100644
index 000000000000..3f260ae48f41
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-9999-zlib.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -105,7 +105,7 @@
+ NSE_HDRS+=nse_libssh2.h
+ NSE_OBJS+=nse_libssh2.o
+ endif
+-ifneq (@LIBZLIB_LIBS@,)
++ifneq (@ZLIB_LIBS@,)
+ NSE_SRC+=nse_zlib.cc
+ NSE_HDRS+=nse_zlib.h
+ NSE_OBJS+=nse_zlib.o
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index d78311ad1c1b..f92eba2649f1 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite,xml"
inherit autotools flag-o-matic git-r3 python-single-r1 toolchain-funcs user
@@ -24,24 +23,26 @@ IUSE="
"
NMAP_LINGUAS=( de fr hi hr it ja pl pt_BR ru zh )
IUSE+=" ${NMAP_LINGUAS[@]/#/linguas_}"
-
REQUIRED_USE="
system-lua? ( nse )
ndiff? ( ${PYTHON_REQUIRED_USE} )
zenmap? ( ${PYTHON_REQUIRED_USE} )
"
-
RDEPEND="
dev-libs/liblinear:=
dev-libs/libpcre
net-libs/libpcap
- libssh2? ( net-libs/libssh2[zlib] )
+ libssh2? (
+ net-libs/libssh2[zlib]
+ sys-libs/zlib
+ )
ndiff? ( ${PYTHON_DEPS} )
nls? ( virtual/libintl )
nmap-update? (
dev-libs/apr
dev-vcs/subversion
)
+ nse? ( sys-libs/zlib )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
@@ -65,6 +66,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-7.25-CXXFLAGS.patch
"${FILESDIR}"/${PN}-7.25-libpcre.patch
"${FILESDIR}"/${PN}-7.31-libnl.patch
+ "${FILESDIR}"/${PN}-9999-zlib.patch
)
S="${WORKDIR}/${MY_P}"
@@ -75,7 +77,7 @@ pkg_setup() {
}
src_prepare() {
- rm -r libpcap/ || die
+ rm -r liblinear/ libpcap/ libpcre/ libssh2/ libz/ || die
cat "${FILESDIR}"/nls.m4 >> "${S}"/acinclude.m4 || die
@@ -135,6 +137,7 @@ src_configure() {
$(use_with ssl openssl) \
$(use_with zenmap) \
$(usex libssh2 --with-zlib) \
+ $(usex nse --with-zlib) \
$(usex nse --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
--cache-file="${S}"/config.cache \
--with-libdnet=included \