summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-01 01:28:52 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-01 01:29:54 +0100
commit62034fa04d7370f9c19c9fda7a257cf9acb2c955 (patch)
tree3efd89cab64b77d817ce2e5685b534fef7ad8880 /net-analyzer
parentnet-analyzer/apinger: Fix CFLAGS=-fno-common (diff)
downloadgentoo-62034fa04d7370f9c19c9fda7a257cf9acb2c955.tar.gz
gentoo-62034fa04d7370f9c19c9fda7a257cf9acb2c955.tar.bz2
gentoo-62034fa04d7370f9c19c9fda7a257cf9acb2c955.zip
net-analyzer/ettercap: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=707674 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ettercap/ettercap-0.8.3.ebuild5
-rw-r--r--net-analyzer/ettercap/ettercap-9999.ebuild5
-rw-r--r--net-analyzer/ettercap/files/ettercap-0.8.3-fno-common.patch22
3 files changed, 30 insertions, 2 deletions
diff --git a/net-analyzer/ettercap/ettercap-0.8.3.ebuild b/net-analyzer/ettercap/ettercap-0.8.3.ebuild
index 5a67e97e5162..f49ef8cf2e4f 100644
--- a/net-analyzer/ettercap/ettercap-0.8.3.ebuild
+++ b/net-analyzer/ettercap/ettercap-0.8.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -47,6 +47,9 @@ DEPEND="${RDEPEND}
test? ( dev-libs/check )
sys-devel/flex
virtual/yacc"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.3-fno-common.patch
+)
src_prepare() {
sed -i "s:Release:Release Gentoo:" CMakeLists.txt || die
diff --git a/net-analyzer/ettercap/ettercap-9999.ebuild b/net-analyzer/ettercap/ettercap-9999.ebuild
index 8db7873acf3e..047be22f8f4c 100644
--- a/net-analyzer/ettercap/ettercap-9999.ebuild
+++ b/net-analyzer/ettercap/ettercap-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -46,6 +46,9 @@ DEPEND="${RDEPEND}
test? ( dev-libs/check )
sys-devel/flex
virtual/yacc"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.3-fno-common.patch
+)
src_prepare() {
sed -i "s:Release:Release Gentoo:" CMakeLists.txt || die
diff --git a/net-analyzer/ettercap/files/ettercap-0.8.3-fno-common.patch b/net-analyzer/ettercap/files/ettercap-0.8.3-fno-common.patch
new file mode 100644
index 000000000000..eddca836905f
--- /dev/null
+++ b/net-analyzer/ettercap/files/ettercap-0.8.3-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/include/ec_threads.h
++++ b/include/ec_threads.h
+@@ -12,7 +12,7 @@
+ };
+
+ /* a value to be used to return errors in fuctcions using pthread_t values */
+-pthread_t EC_PTHREAD_NULL;
++extern pthread_t EC_PTHREAD_NULL;
+ #define EC_PTHREAD_SELF EC_PTHREAD_NULL
+ #define PTHREAD_ID(id) (*(unsigned long*)&(id))
+
+--- a/src/ec_threads.c
++++ b/src/ec_threads.c
+@@ -46,6 +46,8 @@
+ #define INIT_LOCK do{ DEBUG_MSG("thread_init_lock"); pthread_mutex_lock(&init_mtx); } while(0)
+ #define INIT_UNLOCK do{ DEBUG_MSG("thread_init_unlock"); pthread_mutex_unlock(&init_mtx); } while(0)
+
++pthread_t EC_PTHREAD_NULL;
++
+ /* protos... */
+
+ pthread_t ec_thread_detached(char *name, char *desc, void *(*function)(void *), void *args, int detached);