summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-03-26 12:59:20 -0500
committerWilliam Hubbs <williamh@gentoo.org>2018-03-26 13:01:11 -0500
commit71ce84ea58f61d1febcde93d0ee9416bb42709a0 (patch)
tree356f6aeedaecb215d1d56cb8c68e9271899fc3ef /net-analyzer
parentRevert "www-servers/apache: Bye bye apache-2.2" (diff)
downloadgentoo-71ce84ea58f61d1febcde93d0ee9416bb42709a0.tar.gz
gentoo-71ce84ea58f61d1febcde93d0ee9416bb42709a0.tar.bz2
gentoo-71ce84ea58f61d1febcde93d0ee9416bb42709a0.zip
net-analyzer/kapacitor: 1.4.1-r1 bump for service script fixes
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/kapacitor/files/kapacitor.rc6
-rw-r--r--net-analyzer/kapacitor/kapacitor-1.4.1-r1.ebuild48
2 files changed, 53 insertions, 1 deletions
diff --git a/net-analyzer/kapacitor/files/kapacitor.rc b/net-analyzer/kapacitor/files/kapacitor.rc
index 8ee907f66d56..b89d0b1cbf92 100644
--- a/net-analyzer/kapacitor/files/kapacitor.rc
+++ b/net-analyzer/kapacitor/files/kapacitor.rc
@@ -9,12 +9,16 @@ make_pidfile=yes
command_user="kapacitor:kapacitor"
# Logging
-error_log="${error_log:-/var/log/influxdb/influxd.log}"
+error_log="${error_log:-/var/log/kapacitor/kapacitor.err}"
output_log="${output_log:-/dev/null}"
# Max open files
rc_ulimit="-n 65536"
+depend() {
+ after net
+}
+
start_pre() {
# Check if config file exist
if [ ! -r ${config} ]; then
diff --git a/net-analyzer/kapacitor/kapacitor-1.4.1-r1.ebuild b/net-analyzer/kapacitor/kapacitor-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..dd499480fbdd
--- /dev/null
+++ b/net-analyzer/kapacitor/kapacitor-1.4.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/influxdata/kapacitor
+
+inherit golang-build golang-vcs-snapshot systemd user
+
+DESCRIPTION="Monitoring, processing and alerting on time series data"
+HOMEPAGE="https://www.influxdata.com"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+pkg_setup() {
+ enewgroup kapacitor
+ enewuser kapacitor -1 -1 /var/lib/kapacitor kapacitor
+}
+
+src_compile() {
+ pushd "src/${EGO_PN}" > /dev/null || die
+ set -- env GOPATH="${S}" go build -v -work -x ./...
+ echo "$@"
+ "$@" || die "compile failed"
+ popd > /dev/null
+}
+
+src_install() {
+ pushd "src/${EGO_PN}" > /dev/null || die
+ set -- env GOPATH="${S}" go install -v -work -x ./...
+ echo "$@"
+ "$@" || die
+ dobin "${S}"/bin/kapacitor{,d}
+ insinto /etc/kapacitor
+doins etc/kapacitor/kapacitor.conf
+keepdir /etc/kapacitor/load
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/kapacitor
+ systemd_dounit scripts/kapacitor.service
+ keepdir /var/log/kapacitor
+ fowners kapacitor:kapacitor /var/log/kapacitor
+ newconfd "${FILESDIR}"/kapacitor.confd kapacitor
+ newinitd "${FILESDIR}"/kapacitor.rc kapacitor
+ popd > /dev/null || die
+}