summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerb Miller Jr <herb@hlmjr.com>2018-06-11 04:40:37 -0400
committerMichał Górny <mgorny@gentoo.org>2018-06-17 13:14:35 +0200
commit8b1154ee1088d4a6d400e21d54036e396c227c5a (patch)
treefc5ae5c279e6126b55e0b2d8341e19b0658a1f9c /net-dialup
parentxfce-base/xfdesktop: Bump to 4.13.2 (with new Thunar support!) (diff)
downloadgentoo-8b1154ee1088d4a6d400e21d54036e396c227c5a.tar.gz
gentoo-8b1154ee1088d4a6d400e21d54036e396c227c5a.tar.bz2
gentoo-8b1154ee1088d4a6d400e21d54036e396c227c5a.zip
net-dialup/freeradius: Use memcached and rest flags
Only build memcached (dev-libs/memcached) or REST (dev-libs/json-c) modules if appropriate use flags are set. Bug: https://bugs.gentoo.org/656608 Package-Manager: Portage[mgorny]-2.3.24.1
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/freeradius/freeradius-3.0.17.ebuild8
-rw-r--r--net-dialup/freeradius/metadata.xml6
2 files changed, 12 insertions, 2 deletions
diff --git a/net-dialup/freeradius/freeradius-3.0.17.ebuild b/net-dialup/freeradius/freeradius-3.0.17.ebuild
index ff88d4178f9..4ba47a9caa3 100644
--- a/net-dialup/freeradius/freeradius-3.0.17.ebuild
+++ b/net-dialup/freeradius/freeradius-3.0.17.ebuild
@@ -20,8 +20,8 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="
- debug firebird iodbc kerberos ldap libressl mysql odbc oracle pam pcap
- postgres python readline sqlite ssl
+ debug firebird iodbc kerberos ldap libressl memcached mysql odbc oracle pam
+ pcap postgres python readline rest sqlite ssl
"
RESTRICT="test firebird? ( bindist )"
@@ -34,10 +34,12 @@ RDEPEND="!net-dialup/cistronradius
python? ( ${PYTHON_DEPS} )
readline? ( sys-libs/readline:0= )
pcap? ( net-libs/libpcap )
+ memcached? ( dev-libs/libmemcached )
mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql:= )
firebird? ( dev-db/firebird )
pam? ( virtual/pam )
+ rest? ( dev-libs/json-c:= )
ssl? (
!libressl? ( dev-libs/openssl:0=[-bindist] )
libressl? ( dev-libs/libressl:0= )
@@ -73,8 +75,10 @@ src_prepare() {
use ssl || { rm -r src/modules/rlm_eap/types/rlm_eap_{tls,ttls,peap} || die ; }
use ldap || { rm -r src/modules/rlm_ldap || die ; }
use kerberos || { rm -r src/modules/rlm_krb5 || die ; }
+ use memcached || { rm -r src/modules/rlm_cache/drivers/rlm_cache_memcached || die ; }
use pam || { rm -r src/modules/rlm_pam || die ; }
use python || { rm -r src/modules/rlm_python || die ; }
+ use rest || { rm -r src/modules/rlm_rest || die ; }
# Do not install ruby rlm module, bug #483108
rm -r src/modules/rlm_ruby || die
diff --git a/net-dialup/freeradius/metadata.xml b/net-dialup/freeradius/metadata.xml
index fa9540c73dc..566c67956c1 100644
--- a/net-dialup/freeradius/metadata.xml
+++ b/net-dialup/freeradius/metadata.xml
@@ -3,8 +3,14 @@
<pkgmetadata>
<!-- maintainer-needed -->
<use>
+ <flag name="memcached">
+ Include <pkg>dev-libs/libmemcached</pkg> in caching drivers
+ </flag>
<flag name="pcap">
Build the RADIUS sniffer which requires <pkg>net-libs/libpcap</pkg>.
</flag>
+ <flag name="rest">
+ Include support for sending and receiving HTTP requests
+ </flag>
</use>
</pkgmetadata>